Browse Source

Cleaned up packaging and reset version

tags/1.0.1
Clement Lefebvre 5 years ago
parent
commit
b136b67652
8 changed files with 57 additions and 572 deletions
  1. +1
    -26
      README
  2. +4
    -4
      configure.ac
  3. +3
    -478
      debian/changelog
  4. +1
    -9
      debian/control
  5. +1
    -5
      debian/control.in
  6. +47
    -47
      debian/libxplayer-plparser18.symbols
  7. +0
    -1
      debian/rules
  8. +0
    -2
      debian/watch

+ 1
- 26
README View File

@@ -1,34 +1,9 @@

_|_ __|_ _ ._ _
|_(_)|_(/_| | |

playlist parser
xplayer playlist parser

xplayer-pl-parser is a simple GObject-based library to parse a host of
playlist formats, as well as save those

News
====

See NEWS file

Dependencies
============

glib with GIO (glib 2.16)
gmime 2.4

BUGS
====

Bugs should be filed in GNOME's Bugzilla:
http://bugzilla.gnome.org/enter_bug.cgi?product=xplayer&component=playlist%20parser

To get a better debug output, run:
# test-parser --debug

Contact
=======

Bastien Nocera <hadess@hadess.net>
http://www.gnome.org/projects/xplayer/

+ 4
- 4
configure.ac View File

@@ -1,12 +1,12 @@
AC_PREREQ(2.62)

m4_define(xplayer_version_major, 3)
m4_define(xplayer_version_minor, 10)
m4_define(xplayer_version_micro, 2)
m4_define(xplayer_version_major, 1)
m4_define(xplayer_version_minor, 0)
m4_define(xplayer_version_micro, 0)

AC_INIT([xplayer-pl-parser],
[xplayer_version_major.xplayer_version_minor.xplayer_version_micro],
[http://bugzilla.gnome.org/enter_bug.cgi?product=xplayer-pl-parser&component=General])
[http://github.com/linuxmint/xplayer-plparser])

AC_CONFIG_SRCDIR([plparse/xplayer-pl-parser.c])
AC_CONFIG_HEADERS([config.h])


+ 3
- 478
debian/changelog View File

@@ -1,480 +1,5 @@
xplayer-pl-parser (3.10.2-0ubuntu1) trusty; urgency=medium
xplayer-pl-parser (1.0.0) sarah; urgency=medium

* New upstream version

-- Sebastien Bacher <seb128@ubuntu.com> Mon, 31 Mar 2014 16:26:58 +0200

xplayer-pl-parser (3.10.1-0ubuntu1) trusty; urgency=medium

* New upstream version

-- Sebastien Bacher <seb128@ubuntu.com> Wed, 19 Feb 2014 13:46:10 +0100

xplayer-pl-parser (3.10.0-1ubuntu1) trusty; urgency=medium

* Patch m4/libtool.m4 and libtool.m4 for ppc64el.

-- Matthias Klose <doko@ubuntu.com> Sun, 22 Dec 2013 15:36:43 +0100

xplayer-pl-parser (3.10.0-1) experimental; urgency=low

[ Andreas Henriksson ]
* New upstream release.
* Update build-dependencies according to configure.ac:
- Bump libsoup-gnome2.4-dev to >= 2.43.0
- Bump libarchive-dev to >= 3.0
- Drop libquvi-dev (new quvi has incompatible license)
* Rename package for new SONAME (17->18)
* Update debian/libxplayer-plparser18.symbols

[ Michael Biebl ]
* Remove libquvi-dev dependency from libxplayer-plparser-dev, the library no
longer links against libquvi.

[ Sjoerd Simons ]
* Add replaces on libxplayer-plparser17 for the translations

-- Sjoerd Simons <sjoerd@debian.org> Wed, 06 Nov 2013 22:12:24 +0100

xplayer-pl-parser (3.4.5-1) unstable; urgency=low

* New upstream release.
* Upload to unstable.
* The dependency on newer glib versions has been removed by not using
g_clear_pointer(). Lower the Build-Depends accordingly.
* Bump Standards-Version to 3.9.4. No further changes.

-- Michael Biebl <biebl@debian.org> Tue, 04 Jun 2013 01:02:57 +0200

xplayer-pl-parser (3.4.4-1) experimental; urgency=low

* New upstream release.

-- Emilio Pozuelo Monfort <pochu@debian.org> Thu, 28 Mar 2013 02:03:45 +0100

xplayer-pl-parser (3.4.3-1) experimental; urgency=low

* Team upload
* New upstream bug fix release
- build-depend on GLib 2.34, for g_clear_pointer()

-- Simon McVittie <smcv@debian.org> Tue, 23 Oct 2012 17:38:31 +0100

xplayer-pl-parser (3.4.2-1) unstable; urgency=low

* New upstream release.

-- Michael Biebl <biebl@debian.org> Tue, 15 May 2012 20:25:47 +0200

xplayer-pl-parser (3.4.1-1) unstable; urgency=low

* New upstream bug fix release.
* Drop explicit Build-Depends on gir1.2-glib-2.0 and bump Build-Depends on
libgirepository1.0-dev accordingly.

-- Michael Biebl <biebl@debian.org> Mon, 16 Apr 2012 17:20:59 +0200

xplayer-pl-parser (3.4.0-1) unstable; urgency=low

* New upstream release.
* Don't bother setting a shlibs version and just use -V since we have a
symbols file.
* Build gtk-doc documentation.
* Update Vcs-* URLs.
* Bump Standards-Version to 3.9.3.

-- Michael Biebl <biebl@debian.org> Sat, 31 Mar 2012 07:14:01 +0200

xplayer-pl-parser (3.2.0-2) experimental; urgency=low

* Switch to gmime 2.6.

-- Michael Biebl <biebl@debian.org> Fri, 09 Mar 2012 14:16:19 +0100

xplayer-pl-parser (3.2.0-1) experimental; urgency=low

* New upstream release.
* debian/patches/01-libquvi-0.4.patch: Removed, merged upstream.
* debian/control.in: Bump (Build-)Depends on libglib2.0-dev to (>= 2.31.0).

-- Michael Biebl <biebl@debian.org> Fri, 09 Mar 2012 13:39:14 +0100

xplayer-pl-parser (2.32.6-2) unstable; urgency=low

* debian/watch: Track .xz tarballs.
* Bump debhelper compatibility level to 8.
- Strip debian/tmp/ from .install files.
- Bump Build-Depends on debhelper.
* Change section of gir1.2-xplayer-plparser-1.0 to introspection.
* Rely on cdbs to call dh_girepository instead of calling it explicitly.
Bump Build-Depends on cdbs accordingly.
* debian/patches/01-libquvi-0.4.patch:
- Make xplayer-pl-parser build against libquvi 0.4. Patch is backwards
compatible with libquvi 0.2. Thanks Ansgar Burchardt for the patch.
Closes: #651637

-- Michael Biebl <biebl@debian.org> Sun, 11 Dec 2011 00:36:29 +0100

xplayer-pl-parser (2.32.6-1) unstable; urgency=low

* debian/watch: Look for bzip2 tarballs.
* New upstream release:
- Fix parsing of remote RSS feeds
- Add support for M4U/MXU playlists

-- Martin Pitt <mpitt@debian.org> Tue, 27 Sep 2011 08:43:37 +0200

xplayer-pl-parser (2.32.5-2) unstable; urgency=low

* debian/control.in: Add libarchive-dev dependency to libxplayer-plparser-dev
as well.

-- Martin Pitt <mpitt@debian.org> Wed, 25 May 2011 08:37:45 +0200

xplayer-pl-parser (2.32.5-1) unstable; urgency=low

* New upstream release.
- debian/control.in: Bump libquvi-dev build dep and add libarchive-dev
build dep as per configure.in.
* debian/control.in: Add Vcs-* fields.
* debian/watch: Fix syntax to actually catch current version.
* debian/control.in: Bump Standards-Version to 3.9.2 (no changes necessary).

-- Martin Pitt <mpitt@debian.org> Wed, 25 May 2011 08:22:02 +0200

xplayer-pl-parser (2.32.4-3) unstable; urgency=low

* Team upload.
* Upload to unstable to fix pkg-config breakage mistakenly introduced by
2.32.4-1. Closes: #622214

-- Raphaël Hertzog <hertzog@debian.org> Mon, 11 Apr 2011 16:57:29 +0000

xplayer-pl-parser (2.32.4-2) experimental; urgency=low

* Team upload.
* Add libquvi-dev to the dependencies of libxplayer-pl-parser-dev.

-- Raphaël Hertzog <hertzog@debian.org> Sun, 10 Apr 2011 16:59:54 +0000

xplayer-pl-parser (2.32.4-1) experimental; urgency=low

* Team upload.

[ Josselin Mouette ]
* Make the -dev package depend on the gir package.

[ Raphaël Hertzog ]
* New upstream release 2.32.4.
* Drop an unneeded section field (duplication the source entry).

-- Raphaël Hertzog <hertzog@debian.org> Sun, 10 Apr 2011 09:11:40 +0000

xplayer-pl-parser (2.32.2-1) experimental; urgency=low

* New upstream release.
+ debian/control.in:
- Updated build dependencies.
+ debian/libxplayer-plparser17.symbols:
- Updated for the new symbols.

-- Emilio Pozuelo Monfort <pochu@debian.org> Mon, 31 Jan 2011 23:28:34 +0000

xplayer-pl-parser (2.32.1-1) experimental; urgency=low

* New upstream release.
* Update to the new gir policy:
- Rename gir1.0-xplayer-plparser-1.0 to gir1.2-xplayer-plparser-1.0.
- Bump the gobject-introspection build dependency.
- Build depend on gir1.2 packages.
* debian/control.in:
- Remove unneeded libgtk2.0-dev and gir-repository-dev build
dependencies.
* debian/rules,
debian/source/format:
- Switch to source format 3.0 (quilt).
* debian/libxplayer-plparser17.symbols:
- Added.

-- Emilio Pozuelo Monfort <pochu@debian.org> Sat, 18 Dec 2010 17:38:21 +0000

xplayer-pl-parser (2.30.3-1) unstable; urgency=low

* New upstream bugfix release.

-- Sebastian Dröge <slomo@debian.org> Wed, 15 Sep 2010 13:36:36 +0200

xplayer-pl-parser (2.30.2-1) unstable; urgency=low

* debian/control.in:
+ Fix description of the GIR package.
* New upstream bugfix release:
+ debian/control.in:
- Add libsoup-gnome2.4-dev build dependency.
- Update gobject-introspection build dependency to >= 0.6.14.

-- Sebastian Dröge <slomo@debian.org> Wed, 04 Aug 2010 19:13:44 +0200

xplayer-pl-parser (2.30.1-1) unstable; urgency=low

* New upstream bugfix release:
+ debian/control.in:
- Update GLib build dependency to >= 2.24.0.
+ debian/rules:
- Update shlibs version to >= 2.30.1 because of new API.

-- Sebastian Dröge <slomo@debian.org> Wed, 12 May 2010 18:27:59 +0200

xplayer-pl-parser (2.30.0-3) unstable; urgency=low

* Upload to unstable.

-- Sebastian Dröge <slomo@debian.org> Mon, 03 May 2010 13:52:34 +0200

xplayer-pl-parser (2.30.0-2) experimental; urgency=low

* debian/control.in,
debian/gir1.0-xplayer-plparser*.install:
+ Rename GIR package to include the version as required by the GI policy.

-- Sebastian Dröge <slomo@debian.org> Thu, 08 Apr 2010 16:11:49 +0200

xplayer-pl-parser (2.30.0-1) experimental; urgency=low

[ Josselin Mouette ]
* Update copyright, everything is under the LGPL now. Closes: #574343.

[ Sebastian Dröge ]
* New upstream stable release.

-- Sebastian Dröge <slomo@debian.org> Wed, 31 Mar 2010 13:26:39 +0200

xplayer-pl-parser (2.29.92-1) experimental; urgency=low

* New upstream development release:
+ debian/control.in:
- Drop dbus build dependency.

-- Sebastian Dröge <slomo@debian.org> Tue, 16 Mar 2010 09:00:43 +0100

xplayer-pl-parser (2.29.1-1) experimental; urgency=low

* New upstream development release:
+ debian/rules,
debian/control.in,
debian/*install:
- Update for new soname.
+ debian/gir1.0-xplayer-plparser.install,
debian/debian/libxplayer-plparser-dev.install,
debian/control.in,
debian/rules:
- Add support for GObject Introspection.

-- Sebastian Dröge <slomo@debian.org> Wed, 27 Jan 2010 09:14:29 +0100

xplayer-pl-parser (2.28.2-1) unstable; urgency=low

* New upstream bugfix release:
+ debian/patches/01_make-reentrant.patch:
- Dropped, merged upstream.
+ Include gio/gio.h instead of relying on GTK+ to include
it, which it doesn't in older versions (Closes: #558644).
+ debian/rules:
- Update shlibs version for new API.

-- Sebastian Dröge <slomo@debian.org> Fri, 11 Dec 2009 14:36:54 +0100

xplayer-pl-parser (2.28.1-2) unstable; urgency=low

* debian/patches/01_make-reentrant.patch:
+ Patch by Matt Kraai <kraai@ftbfs.org> to make xplayer-pl-parser
reentrant. Fixes crashes in rhythmbox (Closes: #547683).

-- Sebastian Dröge <slomo@debian.org> Thu, 08 Oct 2009 12:53:30 +0200

xplayer-pl-parser (2.28.1-1) unstable; urgency=low

* New upstream bugfix release:
+ debian/control.in:
- Update GLib build dependency.

-- Sebastian Dröge <slomo@debian.org> Tue, 29 Sep 2009 17:39:35 +0200

xplayer-pl-parser (2.28.0-1) unstable; urgency=low

* Merge 2.26.2-2.
* New upstream release.

-- Sebastian Dröge <slomo@debian.org> Mon, 21 Sep 2009 16:46:25 +0200

xplayer-pl-parser (2.27.92-1) experimental; urgency=low

* New upstream development release.
* debian/control.in:
+ Update Standards-Version to 3.8.3.

-- Sebastian Dröge <slomo@debian.org> Tue, 15 Sep 2009 17:29:52 +0200

xplayer-pl-parser (2.27.2-2) experimental; urgency=low

* debian/control.in:
+ Let the -dev package depend on libgmime-2.4-dev as it's required
by some headers.

-- Sebastian Dröge <slomo@debian.org> Sat, 08 Aug 2009 21:26:29 +0200

xplayer-pl-parser (2.27.2-1) experimental; urgency=low

* New upstream development release:
+ debian/control.in:
- Build depend on libgmime-2.4-dev instead of libcamel1.2-dev.
+ debian/rules:
- Update shlibs version to >= 2.27.2 because of API additions.
* debian/control.in:
+ Update Standards-Version to 3.8.2.

-- Sebastian Dröge <slomo@debian.org> Fri, 24 Jul 2009 08:12:47 +0200

xplayer-pl-parser (2.27.1-1) experimental; urgency=low

* New upstream development release.

-- Sebastian Dröge <slomo@debian.org> Mon, 18 May 2009 19:36:07 +0200

xplayer-pl-parser (2.26.2-2) unstable; urgency=low

* debian/patches/30_kfreebsd_gnu.patch:
- Removed, there's no Linux specific code anymore.
* debian/control.in:
- Stop build-depending on libhal-dev, it's not really needed
and as a side effect it will allow xplayer-pl-parser to be built
on non-linux architectures.
- Let libxplayer-plparser-dev depend on ${misc:Depends}.
- libxplayer-plparser12 inherits the section from the source stanza.
- Standards-Version is 3.8.3, no chanes needed.
- Improve long descriptions a bit.
* debian/copyright:
- Add "Copyright" to the packaging copyright statement.
- Clean up some whitespaces.

-- Emilio Pozuelo Monfort <pochu@debian.org> Sat, 29 Aug 2009 00:09:57 +0200

xplayer-pl-parser (2.26.2-1) unstable; urgency=low

[ Josselin Mouette ]
* Build-depend on libglib2.0-doc to ensure proper xrefs.

[ Sebastian Dröge ]
* New upstream bugfix release.
* debian/control.in:
+ Update Standards-Version to 3.8.1.
+ Move debug package to Section debug.

-- Sebastian Dröge <slomo@debian.org> Mon, 18 May 2009 17:38:08 +0200

xplayer-pl-parser (2.26.0-1) unstable; urgency=low

[ Sam Morris ]
* New upstream release.
+ Reduce build-dependency on intltool to 0.35.
+ Increase build-dependency on libglib2.0-dev to 2.17.3.
+ Increase build-dependency on gtk-doc-tools to 1.11.
+ Bump shlibs version info to 2.26.
+ Refresh patch.

-- Josselin Mouette <joss@debian.org> Tue, 07 Apr 2009 15:11:37 +0200

xplayer-pl-parser (2.24.4-1) UNRELEASED; urgency=low

* New upstream release
- uploading to unstable

-- Gustavo Noronha Silva <kov@debian.org> Sat, 14 Mar 2009 11:56:28 -0300

xplayer-pl-parser (2.24.2-1) experimental; urgency=low

[ Sam Morris ]
* New upstream release.
* Build-depend on intltool 0.40.
* Build-depend on glib 2.16.3.
* Drop build-dependency on gnome-vfs.
* Rename libxplayer-plparser10 -> libxplayer-plparser12.
* Move development documentation from libxplayer-plparser10 to
libxplayer-plparser-dev; tweak package descriptions to match; have
libxplayer-plparser-dev Replace libxplayer-plparser10.

[ Sjoerd Simons ]
* debian/control.in: Fix typo in intltool build-depend (0.44 => 0.40)

-- Sjoerd Simons <sjoerd@debian.org> Sat, 06 Dec 2008 13:09:08 +0000

xplayer-pl-parser (2.22.3-2) UNRELEASED; urgency=low

* Properly anchor package name regexp.

-- Loic Minier <lool@dooz.org> Thu, 26 Jun 2008 20:51:28 +0200

xplayer-pl-parser (2.22.3-1) unstable; urgency=low

[ Loic Minier ]
* Fix typo in copyright.

[ Sebastian Dröge ]
* New upstream bugfix release.

-- Sebastian Dröge <slomo@debian.org> Tue, 13 May 2008 11:48:16 +0200

xplayer-pl-parser (2.22.2-2) experimental; urgency=low

* Priority is optional, not extra.
* Add a -dbg package; based on a patch by Matt Kraai; closes: #476214.
- Target at experimental.
- Add a -dbg package in control.
- Bump up cdbs bdep to >= 0.4.37.

-- Loic Minier <lool@dooz.org> Tue, 29 Apr 2008 10:07:27 +0200

xplayer-pl-parser (2.22.2-1) unstable; urgency=low

[ Sam Morris ]
* New upstream release.

[ Sebastian Dröge ]
* Upload to unstable.

-- Sebastian Dröge <slomo@debian.org> Wed, 09 Apr 2008 08:48:55 +0200

xplayer-pl-parser (2.22.1-1) unstable; urgency=low

[ Sam Morris ]
* New upstream development release.
- Build-depend on gtk-doc-tools 1.0.
- build-depend on libglib2.0-dev 2.13.4.
- build-depend on libgnomevfs2-dev 2.16.
- build-depend on libcamel1.2-dev.
* Import 30_kfreebsd_gnu.patch from xplayer package.
* Include check-dist.mk in rules file to prevent accidental uploads to
unstable.

[ Sebastian Dröge ]
* New upstream stable release:
+ debian/control.in:
- Update/wrap build dependencies.
- Add required dependencies to the -dev package.
+ debian/control.in,
debian/libxplayer-plparser*.install:
- Renamed from *11 to *10.
* debian/watch,
debian/rules:
Changes taken from the Ubuntu package
+ Add watch file.
+ Extract libxplayer-plparserN package name from control.
+ Set shlibs version via DEB_DH_MAKESHLIBS_ARGS instead of debian/*.shlibs
as this is less fragile across SONAME changes and library additions.
* debian/rules:
+ Remove check-dist include, upload to unstable.
* debian/copyright:
+ Updated.

-- Sebastian Dröge <slomo@debian.org> Wed, 12 Mar 2008 14:19:22 +0100
* Initial version

-- Clement Lefebvre <root@linuxmint.com> Wed, 27 Jan 2016 15:03:00 +0100

+ 1
- 9
debian/control View File

@@ -1,13 +1,7 @@
# This file is autogenerated. DO NOT EDIT!
#
# Modifications should be made to debian/control.in instead.
# This file is regenerated automatically in the clean target.
Source: xplayer-pl-parser
Section: libs
Priority: optional
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Emilio Pozuelo Monfort <pochu@debian.org>, Michael Biebl <biebl@debian.org>, Sjoerd Simons <sjoerd@debian.org>
Maintainer: Linux Mint <root@linuxmint.com>
Build-Depends: debhelper (>= 8),
autotools-dev,
cdbs (>= 0.4.90),
@@ -24,8 +18,6 @@ Build-Depends: debhelper (>= 8),
libgirepository1.0-dev (>= 0.10.7-1~),
gobject-introspection (>= 0.9.12-4~)
Standards-Version: 3.9.4
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/desktop/unstable/xplayer-pl-parser
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/xplayer-pl-parser

Package: libxplayer-plparser-dev
Section: libdevel


+ 1
- 5
debian/control.in View File

@@ -1,9 +1,7 @@
Source: xplayer-pl-parser
Section: libs
Priority: optional
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: @GNOME_TEAM@
Maintainer: Linux Mint <root@linuxmint.com>
Build-Depends: debhelper (>= 8),
autotools-dev,
cdbs (>= 0.4.90),
@@ -20,8 +18,6 @@ Build-Depends: debhelper (>= 8),
libgirepository1.0-dev (>= 0.10.7-1~),
gobject-introspection (>= 0.9.12-4~)
Standards-Version: 3.9.4
Vcs-Svn: svn://anonscm.debian.org/pkg-gnome/desktop/unstable/xplayer-pl-parser
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-gnome/desktop/unstable/xplayer-pl-parser

Package: libxplayer-plparser-dev
Section: libdevel


+ 47
- 47
debian/libxplayer-plparser18.symbols View File

@@ -1,50 +1,50 @@
libxplayer-plparser-mini.so.18 libxplayer-plparser18 #MINVER#
* Build-Depends-Package: libxplayer-plparser-dev
xplayer_pl_parser_can_parse_from_data@Base 3.10.0
xplayer_pl_parser_can_parse_from_filename@Base 3.10.0
xplayer_pl_parser_can_parse_from_uri@Base 3.10.0
xplayer_pl_parser_can_parse_from_data@Base 1.0.0
xplayer_pl_parser_can_parse_from_filename@Base 1.0.0
xplayer_pl_parser_can_parse_from_uri@Base 1.0.0
libxplayer-plparser.so.18 libxplayer-plparser18 #MINVER#
xplayer_cd_detect_type@Base 3.10.0
xplayer_cd_detect_type_from_dir@Base 3.10.0
xplayer_cd_detect_type_with_url@Base 3.10.0
xplayer_cd_get_human_readable_name@Base 3.10.0
xplayer_cd_has_medium@Base 3.10.0
xplayer_cd_mrl_from_type@Base 3.10.0
xplayer_disc_media_type_quark@Base 3.10.0
xplayer_pl_parser_add_ignored_mimetype@Base 3.10.0
xplayer_pl_parser_add_ignored_scheme@Base 3.10.0
xplayer_pl_parser_can_parse_from_data@Base 3.10.0
xplayer_pl_parser_can_parse_from_filename@Base 3.10.0
xplayer_pl_parser_can_parse_from_uri@Base 3.10.0
xplayer_pl_parser_error_get_type@Base 3.10.0
xplayer_pl_parser_error_quark@Base 3.10.0
xplayer_pl_parser_get_type@Base 3.10.0
xplayer_pl_parser_metadata_get_type@Base 3.10.0
xplayer_pl_parser_new@Base 3.10.0
xplayer_pl_parser_parse@Base 3.10.0
xplayer_pl_parser_parse_async@Base 3.10.0
xplayer_pl_parser_parse_date@Base 3.10.0
xplayer_pl_parser_parse_duration@Base 3.10.0
xplayer_pl_parser_parse_finish@Base 3.10.0
xplayer_pl_parser_parse_with_base@Base 3.10.0
xplayer_pl_parser_parse_with_base_async@Base 3.10.0
xplayer_pl_parser_relative@Base 3.10.0
xplayer_pl_parser_resolve_uri@Base 3.10.0
xplayer_pl_parser_result_get_type@Base 3.10.0
xplayer_pl_parser_save@Base 3.10.0
xplayer_pl_parser_type_get_type@Base 3.10.0
xplayer_pl_playlist_append@Base 3.10.0
xplayer_pl_playlist_get@Base 3.10.0
xplayer_pl_playlist_get_type@Base 3.10.0
xplayer_pl_playlist_get_valist@Base 3.10.0
xplayer_pl_playlist_get_value@Base 3.10.0
xplayer_pl_playlist_insert@Base 3.10.0
xplayer_pl_playlist_iter_first@Base 3.10.0
xplayer_pl_playlist_iter_next@Base 3.10.0
xplayer_pl_playlist_iter_prev@Base 3.10.0
xplayer_pl_playlist_new@Base 3.10.0
xplayer_pl_playlist_prepend@Base 3.10.0
xplayer_pl_playlist_set@Base 3.10.0
xplayer_pl_playlist_set_valist@Base 3.10.0
xplayer_pl_playlist_set_value@Base 3.10.0
xplayer_pl_playlist_size@Base 3.10.0
xplayer_cd_detect_type@Base 1.0.0
xplayer_cd_detect_type_from_dir@Base 1.0.0
xplayer_cd_detect_type_with_url@Base 1.0.0
xplayer_cd_get_human_readable_name@Base 1.0.0
xplayer_cd_has_medium@Base 1.0.0
xplayer_cd_mrl_from_type@Base 1.0.0
xplayer_disc_media_type_quark@Base 1.0.0
xplayer_pl_parser_add_ignored_mimetype@Base 1.0.0
xplayer_pl_parser_add_ignored_scheme@Base 1.0.0
xplayer_pl_parser_can_parse_from_data@Base 1.0.0
xplayer_pl_parser_can_parse_from_filename@Base 1.0.0
xplayer_pl_parser_can_parse_from_uri@Base 1.0.0
xplayer_pl_parser_error_get_type@Base 1.0.0
xplayer_pl_parser_error_quark@Base 1.0.0
xplayer_pl_parser_get_type@Base 1.0.0
xplayer_pl_parser_metadata_get_type@Base 1.0.0
xplayer_pl_parser_new@Base 1.0.0
xplayer_pl_parser_parse@Base 1.0.0
xplayer_pl_parser_parse_async@Base 1.0.0
xplayer_pl_parser_parse_date@Base 1.0.0
xplayer_pl_parser_parse_duration@Base 1.0.0
xplayer_pl_parser_parse_finish@Base 1.0.0
xplayer_pl_parser_parse_with_base@Base 1.0.0
xplayer_pl_parser_parse_with_base_async@Base 1.0.0
xplayer_pl_parser_relative@Base 1.0.0
xplayer_pl_parser_resolve_uri@Base 1.0.0
xplayer_pl_parser_result_get_type@Base 1.0.0
xplayer_pl_parser_save@Base 1.0.0
xplayer_pl_parser_type_get_type@Base 1.0.0
xplayer_pl_playlist_append@Base 1.0.0
xplayer_pl_playlist_get@Base 1.0.0
xplayer_pl_playlist_get_type@Base 1.0.0
xplayer_pl_playlist_get_valist@Base 1.0.0
xplayer_pl_playlist_get_value@Base 1.0.0
xplayer_pl_playlist_insert@Base 1.0.0
xplayer_pl_playlist_iter_first@Base 1.0.0
xplayer_pl_playlist_iter_next@Base 1.0.0
xplayer_pl_playlist_iter_prev@Base 1.0.0
xplayer_pl_playlist_new@Base 1.0.0
xplayer_pl_playlist_prepend@Base 1.0.0
xplayer_pl_playlist_set@Base 1.0.0
xplayer_pl_playlist_set_valist@Base 1.0.0
xplayer_pl_playlist_set_value@Base 1.0.0
xplayer_pl_playlist_size@Base 1.0.0

+ 0
- 1
debian/rules View File

@@ -2,7 +2,6 @@

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
-include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk

libxplayer-plparserN := $(shell sed -rn 's/^Package:[[:space:]]*(libxplayer-plparser[0-9]+)[[:space:]]*$$/\1/p' debian/control)


+ 0
- 2
debian/watch View File

@@ -1,2 +0,0 @@
version=3
http://download.gnome.org/sources/xplayer-pl-parser/([\d\.]+[02468])/xplayer-pl-parser-([\d\.]+)\.tar\.xz

Loading…
Cancel
Save