Commit 792b3581 authored by Jude Nelson's avatar Jude Nelson

Merge tag 'upstream/1.8.18'

Upstream version 1.8.18

Conflicts:
	debian/changelog
	debian/control
	debian/rules
parents 25ca72fd 47c7cfc5
dbus (1.8.18-0+devuan1) jessie; urgency=medium
* New upstream bugfix release
- Hardening: lock down the session bus to only allow EXTERNAL auth by
default, the same as the system bus. This avoids allowing
DBUS_COOKIE_SHA1, which can end up using a predictable random source
on systems where /dev/urandom is unavailable or dbus-daemon runs out
of memory. See the upstream NEWS for more details.
-- Simon McVittie <smcv@debian.org> Thu, 14 May 2015 13:52:50 +0100
dbus (1.8.16-1+devuan1) unstable; urgency=medium
* debian/*: systemd extirpation.
-- Denis Roio <jaromil@dyne.org> Sat, 14 Feb 2015 17:36:21 +0000
dbus (1.8.16-1) unstable; urgency=high
* New upstream release fixes a local denial of service
when using systemd activation (CVE-2015-0245)
-- Simon McVittie <smcv@debian.org> Wed, 04 Feb 2015 20:14:46 +0000
dbus (1.8.14-2) unstable; urgency=high
* Relax the triggers from interest to interest-noawait (Closes: #771989;
mitigates: #776063; partially reopens: #740139).
This is not strictly correct, because the purpose of the triggers
is to set up the .conf, .service files for system services before those
services satisfy dependencies. However, it mitigates #776063
(apt getting into a stuck state during upgrades), and should in
principle be redundant anyway, because dbus-daemon is meant to use
inotify to keep up with configuration changes. See #771989, #776063
for details.
-- Simon McVittie <smcv@debian.org> Tue, 03 Feb 2015 17:28:12 +0000
dbus (1.8.14-1) unstable; urgency=medium
* New upstream release to harden dbus-daemon against packages that install
unsafe security policy configurations.
-- Simon McVittie <smcv@debian.org> Thu, 01 Jan 2015 13:07:23 +0000
dbus (1.8.12-3) unstable; urgency=medium
* preinst: partially revert change from 1.8.12-2. It seems that the
preinst is too late to add a useful dpkg-statoverride entry: dpkg has
already loaded the statoverride database by this point, and if we add
the entry in the preinst, dpkg-statoverride won't run and have
its --update side-effect in the postinst. (Closes: #773107, #773838)
* postinst: don't run dpkg-statoverride with 2>/dev/null: in the unlikely
event that it fails for a reason other than "not overridden" (which
results in silently exiting 1), we'll want to know about it.
-- Simon McVittie <smcv@debian.org> Tue, 23 Dec 2014 21:21:20 +0000
dbus (1.8.12-2) unstable; urgency=medium
* postinst: use dpkg-statoverride to set the permissions for
dbus-daemon-launch-helper (expected to be 04754 root:messagebus)
as suggested in Policy §10.9. This avoids a temporarily broken state
when an upgraded dbus is unpacked but not yet configured (Closes: #773107)
* preinst: opportunistically set up the same dpkg-statoverride entry
if the group already exists, to avoid the same broken state during
upgrades from older versions without needing Pre-Depends: adduser
* postrm: delete the dpkg-statoverride entry on purge
-- Simon McVittie <smcv@debian.org> Sun, 21 Dec 2014 15:02:22 +0000
dbus (1.8.12-1) unstable; urgency=medium
* New upstream release 1.8.12
- increase auth_timeout from 5 seconds back to 30 seconds since it
appears to cause slow or failed boot on some systems, reverting a
change in 1.8.8 (Closes: #769069)
- add a README.Debian to the dbus package documenting how
sysadmins with hostile local users can get the lower timeout back,
if their systems are fast enough to boot correctly like that
-- Simon McVittie <smcv@debian.org> Mon, 24 Nov 2014 13:46:01 +0000
dbus (1.8.10-1) unstable; urgency=medium
* New upstream release 1.8.10
- raise dbus-daemon's file descriptor limit to 65536 to avoid an
opportunity for denial of service
(CVE-2014-7824, an incomplete fix for CVE-2014-3636)
* Start 'dbus-daemon --system' as root under sysvinit (it already
starts as root under systemd), so it can increase its file
descriptor limit
-- Simon McVittie <smcv@debian.org> Thu, 06 Nov 2014 16:28:22 +0000
dbus (1.8.8-2) unstable; urgency=medium
[ Michael Biebl ]
* Build against libsystemd-dev. In systemd v209 the various libraries were
merged into a single libsystemd library.
[ Simon McVittie ]
* debian/dbus.bug-control: when people report bugs against dbus,
also report the status of systemd and systemd-sysv (because
those alter how system service activation works), and dbus-x11
(because that's responsible for normal session bus setup)
* Remove Build-Profiles control field until the syntax settles down
(Closes: #764222)
* Use --with-valgrind=auto (supported since 1.7.6) for the debug build
-- Simon McVittie <smcv@debian.org> Mon, 06 Oct 2014 19:17:04 +0100
dbus (1.8.8-1) unstable; urgency=medium
[ Michael Biebl ]
* Don't attempt config reload if dbus system bus is not running.
[ Simon McVittie ]
* Bump dbus up to Priority: standard because without it, systemd-logind
does not run a getty on tty2..tty6 (matching ftp-master action in
#759293)
* New upstream release fixes several security issues
- CVE-2014-3635: do not accept an extra fd in cmsg padding,
avoiding a buffer overrun in dbus-daemon or system services
- CVE-2014-3636: reduce maximum number of file descriptors
per message from 1024 to 16, to avoid two separate denial-of-service
attacks that could cause system services to be dropped from the bus
- CVE-2014-3637: time out connections that have a
partially-sent message containing a file descriptor, so that
malicious processes cannot use self-referential file descriptors
to make a connection that will never close
- CVE-2014-3638: reduce maximum number of pending replies
per connection to avoid algorithmic complexity DoS
- CVE-2014-3639: reduce timeout for authentication and
do not accept() new connections when all unauthenticated connection
slots are in use, so that malicious processes cannot prevent new
connections to the system bus
* debian/copyright: fix glob syntax, .[ch] is not supported
-- Simon McVittie <smcv@debian.org> Mon, 15 Sep 2014 12:58:25 +0100
dbus (1.8.6-2) unstable; urgency=medium
* debian/dbus.posinst: When triggered only poke the dbus-daemon, don't run
update-rc.d/invoke-rc.d as added by dh_installinit. This prevent some
odd-corner when being triggered during init system upgrade
(Closes: #754404)
-- Sjoerd Simons <sjoerd@debian.org> Wed, 13 Aug 2014 22:30:38 +0200
dbus (1.8.6-1) unstable; urgency=high
* New upstream release
- fix two local DoS vulnerabilities (CVE-2014-3532, CVE-2014-3533)
-- Simon McVittie <smcv@debian.org> Mon, 30 Jun 2014 15:15:58 +0100
dbus (1.8.4-1) unstable; urgency=high
* New upstream release, fixing a DoS vulnerability (CVE-2014-3477)
-- Simon McVittie <smcv@debian.org> Thu, 05 Jun 2014 15:12:02 +0100
dbus (1.8.2-1) unstable; urgency=medium
* New upstream release
-- Simon McVittie <smcv@debian.org> Wed, 30 Apr 2014 20:17:46 +0100
dbus (1.8.0-3) unstable; urgency=medium
* Improve autopkgtest support
- use a shell wildcard instead of dpkg-architecture, to avoid stderr spam
failing the test if gcc is missing
- wrap each test-case in an arbitrary (5 minute) timeout so that one
test-case failing won't halt the whole build
-- Simon McVittie <smcv@debian.org> Wed, 26 Mar 2014 09:17:20 +0000
dbus (1.8.0-2) unstable; urgency=low
* debian/rules: look for DEB_BUILD_PROFILES, the new name for
DEB_BUILD_PROFILE
* Don't try to install systemd units in a stage1 build (they are
no longer installed unless libsystemd*-dev are found) (Closes: #738317)
* Mark dbus-1-doc with Build-Profiles: !stage1
* Register a dpkg trigger on /usr/share/dbus-1/system-services and
/etc/dbus-1/system.d that calls ReloadConfig on the system dbus-daemon,
in case our inotify monitoring isn't completely reliable (see #740139)
* Clean debian/tmp-udeb in `debian/rules clean`
* Hook up the installed tests to DEP-8 metadata
* Add a simple compile/link/run test
-- Simon McVittie <smcv@debian.org> Wed, 26 Feb 2014 13:15:14 +0000
dbus (1.8.0-1) unstable; urgency=low
* New upstream stable release
- add debian/copyright stanzas for some new BSD-licensed cmake macros
-- Simon McVittie <smcv@debian.org> Mon, 20 Jan 2014 15:05:53 +0000
dbus (1.7.10-2) unstable; urgency=low
* Conditionalize libaudit and libcap-ng build-dependencies to [linux-any]
* Explicitly enable libaudit, SELinux and systemd on Linux;
do not enable them elsewhere
-- Simon McVittie <smcv@debian.org> Tue, 07 Jan 2014 12:12:15 +0000
dbus (1.7.10-1) unstable; urgency=low
* Merge from experimental into unstable
* New upstream release 1.7.10 (1.8 rc1)
* Generate debian/dbus.install from a generic part and a Linux-specific
part, since systemd metadata doesn't get installed on non-Linux any more
-- Simon McVittie <smcv@debian.org> Mon, 06 Jan 2014 19:43:36 +0000
dbus (1.7.8-1) experimental; urgency=low
[ Laurent Bigonville ]
* debian/rules: Re-add udeb_configure_flags that were lost during merge
(Closes: #727774)
[ Simon McVittie ]
* Standards-Version: 3.9.5 (no changes needed)
* Enable libaudit support so messages that violate SELinux policy go to the
audit log (Closes: #727771)
* New upstream release
- add new dependency on libsystemd-journal-dev for linux-any
-- Simon McVittie <smcv@debian.org> Tue, 29 Oct 2013 13:07:02 +0000
dbus (1.7.6-2) experimental; urgency=low
* debian/rules: FTBFS if new symbols or libraries are added
without updating the symbols file
* debian/copyright: list copyright holders and minor licenses
(Closes: #726000)
* Merge packaging changes from unstable:
- Run `update-rc.d dbus defaults` instead of deprecated
`update-rc.d dbus start ...` (Closes: #725923)
- Add udeb packages, so the graphical installer can use AT-SPI
(Closes: #723952)
- Standards-Version: 3.9.4 (no changes needed)
-- Simon McVittie <smcv@debian.org> Sat, 12 Oct 2013 16:30:55 +0100
dbus (1.7.6-1) experimental; urgency=low
* Standards-Version: 3.9.4 (no changes needed)
* New upstream development release
- update symbols
-- Simon McVittie <smcv@debian.org> Wed, 09 Oct 2013 16:44:43 +0100
dbus (1.7.4-1) experimental; urgency=low
* New upstream development release
- CVE-2013-2168: avoid a user-triggerable crash (denial of services)
in system services that use libdbus
-- Simon McVittie <smcv@debian.org> Wed, 12 Jun 2013 19:53:00 +0100
dbus (1.7.2-1) experimental; urgency=low
* New upstream development release
* Do the debug build --with-valgrind on mipsel, too
-- Simon McVittie <smcv@debian.org> Thu, 25 Apr 2013 13:46:10 +0100
dbus (1.7.0-1) experimental; urgency=low
* Branch for experimental
* New upstream development release
* On architectures where it's currently supported, do the
debug build with --with-valgrind for better instrumentation
* debian/rules: factor out production and debug configure flags
* Add support for DEB_BUILD_OPTIONS=nodocs, which omits most documentation
(allowing doxygen and xmlto to be avoided) and the dbus-1-doc package
* Add support for DEB_BUILD_PROFILE=stage1, which does the same as nodocs
and additionally makes the debug build not insist on building all tests
* Make the development and debugging packages Multi-Arch: same,
since their arch-dependent files are all arch-segregated
(/usr/lib/TUPLE) or named according to a build-ID (/usr/lib/debug)
(Closes: #689071). This is not actually useful until pkg-config
becomes M-A: foreign (#631275).
-- Simon McVittie <smcv@debian.org> Fri, 22 Feb 2013 15:20:10 +0000
dbus (1.6.18-2) unstable; urgency=medium
* Disable valgrind integration in the debug build on armel,
since valgrind no longer supports armel (Closes: #729136)
-- Simon McVittie <smcv@debian.org> Mon, 02 Dec 2013 10:22:39 +0000
dbus (1.6.18-1) unstable; urgency=low
* Run `update-rc.d dbus defaults` instead of deprecated
`update-rc.d dbus start ...` (Closes: #725923)
* debian/rules: FTBFS if new symbols or libraries are added
without updating the symbols file
* debian/copyright: list copyright holders and minor licenses
(Closes: #726000)
* New upstream release 1.6.18
* Standards-Version: 3.9.5 (no changes needed)
-- Simon McVittie <smcv@debian.org> Fri, 01 Nov 2013 16:30:33 +0000
dbus (1.6.16-1) unstable; urgency=low
* New upstream stable release 1.6.16
* Backport the new dbus-run-session tool from D-Bus 1.7
* Add udeb packages, so the graphical installer can use AT-SPI
(Closes: #723952)
* Standards-Version: 3.9.4 (no changes needed)
-- Simon McVittie <smcv@debian.org> Tue, 08 Oct 2013 16:44:21 +0100
dbus (1.6.14-1) unstable; urgency=low
* New upstream stable release 1.6.14
- fixes an infinite busy-loop if waitpid() is interrupted by a signal
while spawning a subprocess (Closes: #721932)
-- Simon McVittie <smcv@debian.org> Thu, 05 Sep 2013 16:42:55 +0100
dbus (1.6.12-1) unstable; urgency=high
* New upstream stable release 1.6.12
- CVE-2013-2168: avoid a user-triggerable crash (denial of services)
in system services that use libdbus
-- Simon McVittie <smcv@debian.org> Wed, 12 Jun 2013 14:38:34 +0100
dbus (1.6.10-1) unstable; urgency=low
* New upstream stable release 1.6.10
* Merge everything except the upstream development release from experimental:
- On architectures where it's currently supported, do the
debug build with --with-valgrind for better instrumentation
- debian/rules: factor out production and debug configure flags
- Add support for DEB_BUILD_OPTIONS=nodocs, which omits most documentation
(allowing doxygen and xmlto to be avoided) and the dbus-1-doc package
- Add support for DEB_BUILD_PROFILE=stage1, which does the same as nodocs
and additionally makes the debug build not insist on building all tests
- Make the development and debugging packages Multi-Arch: same,
since their arch-dependent files are all arch-segregated
(/usr/lib/TUPLE) or named according to a build-ID (/usr/lib/debug)
(Closes: #689071). This is not actually useful until pkg-config
becomes M-A: foreign (#631275).
* Do the debug build --with-valgrind on mipsel, too
-- Simon McVittie <smcv@debian.org> Wed, 08 May 2013 10:52:51 +0100
dbus (1.6.8-1) unstable; urgency=low
* Merge from experimental
* New upstream stable release 1.6.6
- CVE-2012-3524: avoid arbitrary code execution in setuid or otherwise
privileged binaries that incorrectly use libdbus without first
sanitizing the environment variables inherited from their
less-privileged caller (Closes: #689070)
* New upstream stable release 1.6.8
- Revert part of 1.6.6 (do not check filesystem capabilities, only
setuid/setgid), fixing regressions in certain configurations of
gnome-keyring
-- Simon McVittie <smcv@debian.org> Sat, 29 Sep 2012 13:25:50 +0100
dbus (1.6.4-1) experimental; urgency=low
* gbp.conf: switch to experimental branch
* New upstream stable release
- remove incorrect assertion and have correct default for developer mode
(Closes: #680027, differently)
-- Simon McVittie <smcv@debian.org> Wed, 18 Jul 2012 18:42:52 +0100
dbus (1.6.2-2) unstable; urgency=low
* Disable "developer mode", which was intended to be off-by-default,
but was incorrectly on-by-default in 1.6.2, causing an incorrect
assertion to be hit when starting fcitx before dbus-launch.
(Closes: #680027)
-- Simon McVittie <smcv@debian.org> Tue, 03 Jul 2012 19:33:42 +0100
dbus (1.6.2-1) unstable; urgency=low
* New upstream stable release
- dbus-launch --exit-with-session no longer monitors its stdin if
run under X11 (Closes: #453755)
* Remove the workaround for #453755 from dbus-Xsession
-- Simon McVittie <smcv@debian.org> Wed, 27 Jun 2012 18:22:20 +0100
dbus (1.6.0-1) unstable; urgency=low
* Merge from "experimental" (1.5.12 was accidentally uploaded to unstable)
* New upstream stable release
* debian/watch: only match stable (0.even.x) releases
-- Simon McVittie <smcv@debian.org> Tue, 05 Jun 2012 14:23:46 +0100
dbus (1.5.12-1) unstable; urgency=low
* Merge from unstable
* New upstream release
- adds new API
* Standards-Version: 3.9.3 (no changes)
* Remove lintian override for #629648, hopefully the ftpmasters are using
lintian 2.5.1 by now
* Add lintian overrides for the empty directories we (intentionally) ship
* Don't run dh_makeshlibs on dbus-1-dbg, nothing should be linking to its
extra-debug-enabled build of the library
* Register D-Bus documentation in doc-base
-- Simon McVittie <smcv@debian.org> Tue, 27 Mar 2012 18:36:38 +0100
dbus (1.4.20-1) unstable; urgency=low
* New upstream release
- fixes FTBFS with GLib 2.32 (Closes: #665665)
-- Simon McVittie <smcv@debian.org> Tue, 27 Mar 2012 13:33:33 +0100
dbus (1.5.10-1) experimental; urgency=low
* New upstream release
* Merge from unstable
* Build with systemd console-user-checking support
* Use debhelper 9 (mainly for compressed, build-ID-based debug symbols),
and dpkg's default.mk instead of hardening-includes
-- Simon McVittie <smcv@debian.org> Tue, 21 Feb 2012 18:24:14 +0000
dbus (1.4.18-1) unstable; urgency=low
* New upstream release
* Change dbus and src:dbus from Section: devel to Section: admin
(Closes: #659357)
-- Simon McVittie <smcv@debian.org> Mon, 13 Feb 2012 17:17:43 +0000
dbus (1.5.8-1) experimental; urgency=low
* Merge from unstable
* New upstream release
-- Simon McVittie <smcv@debian.org> Wed, 21 Sep 2011 18:32:46 +0100
dbus (1.4.16-1) unstable; urgency=low
* New upstream release
* Do not symlink dcop-howto.txt.gz - no longer installed (this is D-Bus,
not DCOP)
* Set the build-dependencies to be enough to run all tests, but don't
run the tests yet
-- Simon McVittie <smcv@debian.org> Wed, 21 Sep 2011 15:32:10 +0100
dbus (1.5.6-1) experimental; urgency=low
* Merge from unstable
* New upstream release
-- Simon McVittie <smcv@debian.org> Fri, 29 Jul 2011 16:56:04 +0100
dbus (1.4.14-1) unstable; urgency=low
* New upstream release
- no longer needs workarounds to build or install the documentation
* Remove --disable-gc-sections, unnecessary since 1.4.12
-- Simon McVittie <smcv@debian.org> Fri, 29 Jul 2011 16:50:56 +0100
dbus (1.5.4-3) experimental; urgency=low
* Merge from unstable
-- Simon McVittie <smcv@debian.org> Fri, 15 Jul 2011 11:26:08 +0100
dbus (1.4.12-5) unstable; urgency=low
* Undo the changed invocation for dbus-launch, which seems to cause
more problems than it solves (LP: #807614, LP: #809900, probably also
Closes: #633652)
* Work around #453755 by just reopening stdin from /dev/null instead,
until fd.o #39197 gets fixed
-- Simon McVittie <smcv@debian.org> Fri, 15 Jul 2011 10:45:56 +0100
dbus (1.4.12-4) unstable; urgency=low
* Override missing-pre-dependency-on-multiarch-support for the -dev
package, ftp-master doesn't have lintian 2.5.1 yet
* Check all Description fields for correct use of dbus (package name)
vs. D-Bus (project name), and override lintian false-positives
-- Simon McVittie <smcv@debian.org> Fri, 01 Jul 2011 07:55:01 +0100
dbus (1.4.12-3) unstable; urgency=low
* Mention CVE-2011-2200 in the changelog for 1.4.12-1 now it has a CVE ID
* Merge some things from Ubuntu, via experimental:
- move libraries into multiarch locations (but don't move binaries
from /usr to /, which is not needed on Debian)
- run dbus-uuidgen --ensure in postinst
- call ReloadConfig with dbus-send in the postinst, since that'll work
regardless of whether dbus was started with sysvinit or Upstart; just
call it unconditionally, and ignore any failures we might see (in
chroots or if dbus-daemon wasn't running)
* and more things from experimental:
- improve comments in postinst explaining why it behaves as it does
* Run dbus-launch for X sessions in a way that doesn't consume characters
from startx's stdin, or the stdin of certain display managers' init scripts
(known to affect slim, but not xdm or gdm) (Closes: #453755)
* Remove the .la file for the debug build, not just the normal build
-- Simon McVittie <smcv@debian.org> Thu, 30 Jun 2011 17:21:03 +0100
dbus (1.5.4-2) experimental; urgency=low
* Merge from unstable
-- Simon McVittie <smcv@debian.org> Sat, 11 Jun 2011 19:33:40 +0100
dbus (1.4.12-2) unstable; urgency=medium
* Don't run tests during build (again), it appears they time out on most of
of the buildds
* Explicitly build-depend on automake 1.10, so buildds won't try and fail
with automake1.9 like kfreebsd-i386 did
-- Simon McVittie <smcv@debian.org> Sat, 11 Jun 2011 14:11:04 +0100
dbus (1.5.4-1) experimental; urgency=low
* Merge from unstable
* New(er) upstream version fixing local DoS (Closes: #629938)
* Revert some of the changes merged from Ubuntu, which look as though
they shouldn't be needed on either distribution:
- there's no need to create/chown messagebus' home directory, the sysvinit
script and the Upstart job both do that on-demand
* Revert changes which are useful in Ubuntu but not Debian:
- move everything except the library back into /usr; Debian doesn't have
any uses for dbus-daemon in early boot, and if we do later, we'd need to
get libexpat moved first
- this gets the locations back into sync with what it says in the
Xsession hook (Closes: #630011) and the init script (Closes: #629954)
* Improve comments in postinst explaining why it behaves as it does
-- Simon McVittie <smcv@debian.org> Fri, 10 Jun 2011 23:35:51 +0100
dbus (1.4.12-1) unstable; urgency=medium
* New upstream release fixes local DoS (Closes: #629938, CVE-2011-2200)
* Don't delete jquery.js, no longer installed by recent Doxygen
* Build-depend on libglib2.0-dev, libdbus-glib-1-dev for better regression
test coverage (dbus-glib is a circular dependency, but both of these
dependencies can be dropped if bootstrapping new architectures)
-- Simon McVittie <smcv@debian.org> Fri, 10 Jun 2011 22:39:14 +0100
dbus (1.5.2-2) experimental; urgency=low
* Merge from unstable
* Merge and adapt from Ubuntu:
- create, chown messagebus' home directory in postinst
- run dbus-uuidgen --ensure in postinst
- call ReloadConfig with dbus-send in the postinst, since that'll work
regardless of whether dbus was started with sysvinit or Upstart; just
call it unconditionally, and ignore any failures we might see (in
chroots or if dbus-daemon wasn't running)
- move dbus-daemon and its helpers from /usr to /
- move libraries into multiarch locations
* Don't delete jquery.js, no longer installed by recent Doxygen
* libdbus-1-dev: explicitly pre-depend on multiarch-support to work around
debhelper and lintian disagreeing whether it's necessary
-- Simon McVittie <smcv@debian.org> Thu, 09 Jun 2011 08:00:24 +0100
dbus (1.4.10-2) unstable; urgency=low
* Disable silent rules so we can have useful buildd logs
* Update Vcs-Git, Vcs-Browser to the form preferred by the Alioth admins
* Disable -Wl,--gc-sections and related flags: the size decrease is
negligible, and these options currently segfault ld on armel and mips*
(Closes: #628834)
* Disable the build-time tests for now, they need more upstream work before
they'll pass in a minimal build chroot
-- Simon McVittie <smcv@debian.org> Thu, 02 Jun 2011 17:08:25 +0100
dbus (1.5.2-1) experimental; urgency=low
* Merge from unstable
* New(er) upstream version
-- Simon McVittie <smcv@debian.org> Wed, 01 Jun 2011 16:32:25 +0100
dbus (1.4.10-1) unstable; urgency=low
* New upstream version
* Use a separate build directory
* Explicitly set compiler flags
* Don't complain about not installing libdbus-1.la
* Don't pass a version to dh_makeshlibs -V - the symbols file gives us
exact dependencies, so the legacy shlibs mechanism is just a guard against
old systems now, and everyone forgets to update it
* Do a second build with tests, verbosity etc. enabled, and install it
in /usr/lib/$DEB_HOST_MULTIARCH/dbus-1.0/debug-build in dbus-1-dbg
(Closes: #498185)
- increase dependencies of dbus-1-dbg to allow for this
- run the debug build's regression tests during build, but don't make
failures fatal yet
- build-depend on xvfb and run the tests under xvfb-run, since one
needs a $DISPLAY
* Run autoconf during build, and allow parallel building
* Don't install dcop-howto.txt - this isn't DCOP
-- Simon McVittie <smcv@debian.org> Wed, 01 Jun 2011 16:18:45 +0100
dbus (1.5.0-2) experimental; urgency=low
* Merge from unstable
-- Simon McVittie <smcv@debian.org> Wed, 27 Apr 2011 16:41:52 +0100
dbus (1.4.8-3) unstable; urgency=low
* libdbus-1-3 Breaks versions of kdebase-workspace-bin and kde-window-manager
that suffer from #623492, so partial upgrades don't make KDE unusable
(Closes: #624333)
* Policy 3.9.2 (no changes required)
* De-duplicate short descriptions
* Add DEP-3 metadata to 01_no-fatal-warnings.patch
-- Simon McVittie <smcv@debian.org> Wed, 27 Apr 2011 16:11:18 +0100
dbus (1.4.8-2) unstable; urgency=low
* Remove jquery.js at the right location
* Re-upload with non-broken .changes file
-- Simon McVittie <smcv@debian.org> Tue, 19 Apr 2011 09:15:04 +0100
dbus (1.5.0-1) experimental; urgency=low
* New upstream development version (targeting experimental)
* Remove jquery.js at the right location
-- Simon McVittie <smcv@debian.org> Mon, 11 Apr 2011 18:04:56 +0100
dbus (1.4.8-1) unstable; urgency=low
* New upstream version
- Use upstream-merged support for installing HTML docs
- Use upstream-supplied doxygen_to_devhelp.xsl (the Automake integration
is still a bit broken, so we build it ourselves)
* Mark dbus, dbus-x11 as Multi-Arch: foreign
* Remove the unused copy of jquery.js that doxygen now wants to install
* Move HTML and text documentation from /u/s/d/dbus-1-doc to /u/s/d/dbus
(see Policy bug #107073 for discussion), leaving behind symlinks to their
historical locations; this also results in shipping one copy of
dbus-specification.html rather than two
* Correctly credit Michael for his changes in the previous changelog entry
-- Simon McVittie <smcv@debian.org> Mon, 11 Apr 2011 16:22:48 +0100
dbus (1.4.6-1) unstable; urgency=low
[ Michael Biebl ]
* Switch from cdbs to dh.
* Bump debhelper compatibility level to 8.
* Remove doxygen call from debian/rules and cleaning up doc/api manually.
The upstream build system takes care of that already.
[ Simon McVittie ]
* New upstream version
- remove 00_dbus-quiesce-startup-errors.patch, no longer needed
* Ignore changes to generated Doxygen HTML instead of deleting it in clean,
for easier use of git-buildpackage
* Unapply patches after building from git
-- Simon McVittie <smcv@debian.org> Thu, 17 Feb 2011 20:12:59 +0000
dbus (1.4.1-2) unstable; urgency=low
[ Simon McVittie ]
* Move to git; add debian/gbp.conf for git-buildpackage
* Replace 00_dbus-quiesce-startup-errors.patch with the version that was
merged upstream
[ Michael Biebl ]
* Upload to unstable.
-- Michael Biebl <biebl@debian.org> Mon, 07 Feb 2011 01:52:08 +0100
dbus (1.4.1-1) experimental; urgency=low