Commit bc668b9a authored by Daniel Reurich's avatar Daniel Reurich

fix error with debian/source/options with gitsrc

parent 588f3ff2
......@@ -389,18 +389,17 @@ git_source_options() {
opt_ref=$(git config --file ${file} --get git-ref 2>&- || true)
fi
if [ -z "${opt_depth:-}" ]; then
echo "Setting git source depth to $GIT_DEPTH"
DBP_EXTRA_OPTS="${DBP_EXTRA_OPTS:-} --source-option=--git-depth=$GIT_DEPTH"
else
echo "Using source depth of $opt_depth as defined in debian/source/options"
$GIT_DEPTH=${opt_depth}
fi
if ![ -z "${opt_ref:-}" ]; then
echo "Setting git source ref to $GIT_REF"
DBP_EXTRA_OPTS="${DBP_EXTRA_OPTS:-} --source-option=--git-ref=${BRANCH}"
echo "Setting git depth to $GIT_DEPTH"
DBP_EXTRA_OPTS="${DBP_EXTRA_OPTS:-} --source-option=--git-depth=$GIT_DEPTH"
if [ -z "${opt_ref:-}" ]; then
echo "Adding git source ref: ${opt_ref}"
DBP_EXTRA_OPTS="${DBP_EXTRA_OPTS:-} --source-option=--git-ref=${opt_ref}"
else
echo "Settin git source ref to $opt_ref as defined in debian/source/options"
DBP_EXTRA_OPTS="${DBP_EXTRA_OPTS:-} --source-option=--git-ref=${BRANCH}"
fi
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment