Commit 3375090d authored by Colin Watson's avatar Colin Watson

Fix old Debian scripts and all Ubuntu scripts cope with Anthony's change

in 1.0.8 to make --second-stage not bother recalculating required and
base.

r57240
parent ac2d34b3
......@@ -4,6 +4,9 @@ debootstrap (1.0.11) UNRELEASED; urgency=low
* Clarify that --second-stage is needed to complete the bootstrapping
process after --foreign.
* Fix --make-tarball= option (closes: #484869).
* Fix old Debian scripts and all Ubuntu scripts cope with Anthony's change
in 1.0.8 to make --second-stage not bother recalculating required and
base.
-- Colin Watson <cjwatson@ubuntu.com> Fri, 31 Oct 2008 13:37:01 +0000
......
mirror_style release
download_style apt var-state
LIBC=libc6
if [ "$ARCH" = alpha ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils debconf-tiny debianutils diff dpkg e2fsprogs fileutils findutils grep gzip hostname ldso libc6 libdb2 libgdbmg1 libncurses5 libnewt0 libpam-modules libpam-runtime libpam0g libpopt0 libreadline4 libstdc++2.10 login makedev mawk modutils mount ncurses-base ncurses-bin passwd perl-5.005-base perl-base procps sed shellutils slang1 sysklogd sysvinit tar textutils update util-linux whiptail"
......@@ -10,12 +15,9 @@ work_out_debs () {
echo "$2" | tr ' ' '\n' | grep -v "^$1$" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"alpha")
required="$(without_package "libc6" "$required") libc6.1"
LIBC6="libc6.1"
;;
"i386")
base="$base fdflush isapnptools lilo mbr pciutils pcmcia-cs psmisc setserial syslinux"
......@@ -82,7 +84,7 @@ second_stage_install () {
x_core_install dpkg
ln -sf /usr/share/zoneinfo/UTC "$TARGET/etc/localtime"
x_core_install $LIBC6
x_core_install $LIBC
smallyes '' | x_core_install perl-5.005-base
x_core_install mawk
......
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils coreutils libacl1 libattr1 debconf debconf-i18n liblocale-gettext-perl libtext-wrapi18n-perl libtext-charwidth-perl debianutils diff dpkg dselect libblkid1 e2fsprogs e2fslibs libcomerr2 libss2 libuuid1 findutils grep gzip hostname libcap1 libc6 libdb1-compat libdb3 libncurses5 libnewt0.51 libpam-modules libpam-runtime libpam0g libperl5.8 libpopt0 login makedev mawk modutils mount ncurses-base ncurses-bin passwd perl-base procps sed slang1a-utf8 initscripts sysvinit sysv-rc tar util-linux whiptail libgcc1 gcc-3.3-base libstdc++5"
......@@ -14,14 +19,12 @@ work_out_debs () {
echo "$3" | tr ' ' '\n' | sed "s/^$1$/$2/" | tr '\n' ' '
}
LIBC6=libc6
IPFWTOOL=iptables
case $ARCH in
"alpha")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$base pciutils"
LIBC6="libc6.1"
IPFWTOOL="ipchains"
;;
"arm")
......@@ -36,7 +39,6 @@ work_out_debs () {
"ia64")
required="$(subst_package "libc6" "libc6.1" "$required") libreadline4"
base="$base elilo efibootmgr dosfstools libparted1.6-12 parted"
LIBC6="libc6.1"
;;
"m68k")
required="$required libreadline4"
......@@ -161,7 +163,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTBASE "Installing base system" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTBASE "Installing base system" #5
x_core_install perl-base
......
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils coreutils debianutils diff dpkg dselect e2fslibs e2fsprogs findutils gcc-3.3-base grep gzip hostname initscripts libacl1 libattr1 libblkid1 libc6 libcap1 libcomerr2 libdb1-compat libdb3 libgcc1 libncurses5 libpam-modules libpam-runtime libpam0g libss2 libstdc++5 libuuid1 login mawk mount ncurses-base ncurses-bin passwd perl-base sed slang1a-utf8 sysv-rc sysvinit tar util-linux zlib1g"
......@@ -14,13 +19,10 @@ work_out_debs () {
echo "$3" | tr ' ' '\n' | sed "s/^$1$/$2/" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"alpha")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
"arm")
;;
......@@ -29,7 +31,6 @@ work_out_debs () {
"ia64")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
"m68k")
;;
......@@ -122,7 +123,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTBASE "Installing base system" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTBASE "Installing base system" #5
x_core_install perl-base
......
......@@ -3,6 +3,11 @@ test "$FAKECHROOT" = "true" || error 1 FAKECHROOTREQ "This variant requires fake
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils coreutils debianutils diff dpkg dselect e2fslibs e2fsprogs findutils gcc-3.3-base grep gzip hostname initscripts libacl1 libattr1 libblkid1 libc6 libcap1 libcomerr2 libdb1-compat libdb3 libgcc1 libncurses5 libpam-modules libpam-runtime libpam0g libss2 libstdc++5 libuuid1 login mawk mount ncurses-base ncurses-bin passwd perl-base sed slang1a-utf8 sysv-rc sysvinit tar util-linux zlib1g"
......@@ -19,13 +24,10 @@ work_out_debs () {
required="$required binutils fakechroot"
base="$(without_package "binutils" "$base")"
LIBC6=libc6
case $ARCH in
"alpha")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
"arm")
;;
......@@ -34,7 +36,6 @@ work_out_debs () {
"ia64")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
"m68k")
;;
......@@ -128,7 +129,7 @@ second_stage_install () {
install_fakechroot_tools
p; progress $baseprog $bases INSTBASE "Installing base system" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTBASE "Installing base system" #5
x_core_install perl-base
......
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils debconf debianutils diff dpkg e2fsprogs fileutils findutils grep gzip hostname libcap1 libc6 libdb2 libdb3 libncurses5 libnewt0 libpam-modules libpam-runtime libpam0g libperl5.6 libpopt0 libreadline4 libstdc++2.10-glibc2.2 login makedev mawk modutils mount ncurses-base ncurses-bin passwd perl-base procps sed shellutils slang1 sysvinit tar textutils util-linux whiptail"
......@@ -11,14 +16,12 @@ work_out_debs () {
echo "$2" | tr ' ' '\n' | grep -v "^$1$" | tr '\n' ' '
}
LIBC6=libc6
IPFWTOOL=iptables
case $ARCH in
"alpha")
required="$(without_package "libc6" "$required") libc6.1"
base="$base setserial aboot pciutils"
LIBC6="libc6.1"
IPFWTOOL="ipchains"
;;
"arm")
......@@ -33,7 +36,6 @@ work_out_debs () {
"ia64")
required="$(without_package "libc6" "$required") libc6.1 gcc-2.96-base"
base="$base elilo efibootmgr dosfstools libparted1.4 parted"
LIBC6="libc6.1"
;;
"m68k")
base="$base atari-bootstrap atari-fdisk amiga-fdisk eject mac-fdisk pmac-fdisk-cross setserial vmelilo"
......@@ -146,7 +148,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTBASE "Installing base system" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTBASE "Installing base system" #5
x_core_install perl-base
......
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils debianutils diff dpkg e2fsprogs fileutils findutils grep gzip hostname libc6 libcap1 libdb3 libgdbmg1 libncurses5 libpam-modules libpam-runtime libpam0g libperl5.6 libstdc++2.10-glibc2.2 login mawk mount ncurses-base ncurses-bin perl-base sed shellutils slang1 sysvinit tar textutils util-linux"
......@@ -11,13 +16,10 @@ work_out_debs () {
echo "$2" | tr ' ' '\n' | grep -v "^$1$" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"alpha")
required="$(without_package "libc6" "$required") libc6.1"
base="$(without_package "libc6-dev" "$base") libc6.1-dev"
LIBC6="libc6.1"
;;
"arm")
;;
......@@ -29,7 +31,6 @@ work_out_debs () {
base="$(without_package "gcc-2.95" "$base") gcc-2.96"
base="$(without_package "g++-2.95" "$base") g++-2.96"
base="$(without_package "libc6-dev" "$base") libc6.1-dev elilo efibootmgr dosfstools libparted1.4 parted"
LIBC6="libc6.1"
;;
"m68k")
;;
......@@ -122,7 +123,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTBASE "Installing base system" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTBASE "Installing base system" #5
x_core_install perl-base
......
......@@ -4,10 +4,12 @@ download_style apt
finddebs_style from-indices
variants - buildd
work_out_debs () {
LIBC6=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then LIBC6="libc6.1"; fi
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="$(get_debs Priority: required)"
if doing_variant -; then
......@@ -20,7 +22,7 @@ work_out_debs () {
add () { if [ "$ARCH" = "$1" ]; then eval "$2=\"\$$2 $3\""; fi; }
base="apt binutils cpio cpp cpp-4.0 dpkg-dev g++ g++-4.0 gcc gcc-4.0 gcc-4.0-base ${LIBC6}-dev libdb4.2 libgdbm3 libstdc++6 libstdc++6-4.0-dev linux-kernel-headers make patch perl perl-modules"
base="apt binutils cpio cpp cpp-4.0 dpkg-dev g++ g++-4.0 gcc gcc-4.0 gcc-4.0-base ${LIBC}-dev libdb4.2 libgdbm3 libstdc++6 libstdc++6-4.0-dev linux-kernel-headers make patch perl perl-modules"
add ia64 base "libunwind7-dev"
add sparc base "lib64gcc1"
......@@ -101,7 +103,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -11,10 +11,12 @@ download_style apt
finddebs_style from-indices
variants - buildd
work_out_debs () {
LIBC6=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then LIBC6="libc6.1"; fi
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="$(get_debs Priority: required)"
if doing_variant -; then
......@@ -27,7 +29,7 @@ work_out_debs () {
add () { if [ "$ARCH" = "$1" ]; then eval "$2=\"\$$2 $3\""; fi; }
base="apt binutils cpio cpp cpp-4.0 dpkg-dev g++ g++-4.0 gcc gcc-4.0 ${LIBC6}-dev libgdbm3 libstdc++6 libstdc++6-4.0-dev linux-kernel-headers make patch perl perl-modules"
base="apt binutils cpio cpp cpp-4.0 dpkg-dev g++ g++-4.0 gcc gcc-4.0 ${LIBC}-dev libgdbm3 libstdc++6 libstdc++6-4.0-dev linux-kernel-headers make patch perl perl-modules"
add ia64 base "libunwind7-dev"
add sparc base "lib64gcc1"
......@@ -106,7 +108,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -15,10 +15,12 @@ if doing_variant fakechroot; then
test "$FAKECHROOT" = "true" || error 1 FAKECHROOTREQ "This variant requires fakechroot environment to be started"
fi
work_out_debs () {
LIBC6=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then LIBC6="libc6.1"; fi
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="$(get_debs Priority: required)"
if doing_variant -; then
......@@ -31,7 +33,7 @@ work_out_debs () {
add () { if [ "$ARCH" = "$1" ]; then eval "$2=\"\$$2 $3\""; fi; }
base="apt binutils cpio cpp cpp-4.1 dpkg-dev g++ g++-4.1 gcc gcc-4.1 ${LIBC6}-dev libdb4.4 libgdbm3 libstdc++6 libstdc++6-4.1-dev linux-libc-dev make patch perl perl-modules"
base="apt binutils cpio cpp cpp-4.1 dpkg-dev g++ g++-4.1 gcc gcc-4.1 ${LIBC}-dev libdb4.4 libgdbm3 libstdc++6 libstdc++6-4.1-dev linux-libc-dev make patch perl perl-modules"
add ia64 base "libunwind7-dev"
add sparc base "lib64gcc1"
......@@ -124,7 +126,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -15,10 +15,12 @@ if doing_variant fakechroot; then
test "$FAKECHROOT" = "true" || error 1 FAKECHROOTREQ "This variant requires fakechroot environment to be started"
fi
work_out_debs () {
LIBC6=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then LIBC6="libc6.1"; fi
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="$(get_debs Priority: required)"
if doing_variant -; then
......@@ -31,7 +33,7 @@ work_out_debs () {
add () { if [ "$ARCH" = "$1" ]; then eval "$2=\"\$$2 $3\""; fi; }
base="apt binutils cpio cpp cpp-4.1 dpkg-dev g++ g++-4.1 gcc gcc-4.1 ${LIBC6}-dev libdb4.4 libgdbm3 libstdc++6 libstdc++6-4.1-dev linux-libc-dev make patch perl perl-modules"
base="apt binutils cpio cpp cpp-4.1 dpkg-dev g++ g++-4.1 gcc gcc-4.1 ${LIBC}-dev libdb4.4 libgdbm3 libstdc++6 libstdc++6-4.1-dev linux-libc-dev make patch perl perl-modules"
add ia64 base "libunwind7-dev"
add sparc base "lib64gcc1"
......@@ -124,7 +126,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -15,10 +15,12 @@ if doing_variant fakechroot; then
test "$FAKECHROOT" = "true" || error 1 FAKECHROOTREQ "This variant requires fakechroot environment to be started"
fi
work_out_debs () {
LIBC6=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then LIBC6="libc6.1"; fi
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="$(get_debs Priority: required)"
if doing_variant -; then
......@@ -114,7 +116,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -2,6 +2,11 @@ default_mirror http://old-releases.ubuntu.com/ubuntu
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils coreutils libacl1 libattr1 debconf debconf-i18n liblocale-gettext-perl libtext-iconv-perl libtext-wrapi18n-perl libtext-charwidth-perl debianutils diff dpkg dselect libblkid1 e2fsprogs e2fslibs libcomerr2 libss2 libuuid1 findutils grep gzip hostname libcap1 libdb1-compat libdb3 libncurses5 libnewt0.51 libpam-modules libpam-runtime libpam0g libpopt0 login makedev mawk mount ncurses-base ncurses-bin passwd perl-base procps python-minimal python2.4-minimal sed slang1a-utf8 lsb-base initscripts sysvinit sysv-rc tar util-linux zlib1g whiptail libgcc1 gcc-3.3-base libstdc++5"
......@@ -15,8 +20,6 @@ work_out_debs () {
echo "$3" | tr ' ' '\n' | sed "s/^$1$/$2/" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"i386")
required="$required libc6 libc6-i686"
......@@ -33,7 +36,6 @@ work_out_debs () {
"ia64")
required="$required libc6.1 libunwind7"
base="$base dmidecode libreadline4"
LIBC6="libc6.1"
;;
"sparc")
required="$required libc6"
......@@ -121,7 +123,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -2,6 +2,11 @@ default_mirror http://old-releases.ubuntu.com/ubuntu
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils build-essential coreutils debianutils diff dpkg dselect e2fslibs e2fsprogs fakeroot findutils gcc-3.3-base grep gzip hostname initscripts libacl1 libattr1 libblkid1 libc6 libcap1 libcomerr2 libdb1-compat libdb3 libgcc1 libncurses5 libpam-modules libpam-runtime libpam0g libss2 libstdc++5 libuuid1 login lsb-base mawk mount ncurses-base ncurses-bin passwd perl-base pkgstriptranslations python-minimal python2.4-minimal sed slang1a-utf8 sysv-rc sysvinit tar util-linux zlib1g"
......@@ -14,8 +19,6 @@ work_out_debs () {
echo "$3" | tr ' ' '\n' | sed "s/^$1$/$2/" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"amd64")
;;
......@@ -27,14 +30,12 @@ work_out_debs () {
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
base="$base libunwind7 libunwind7-dev"
LIBC6="libc6.1"
;;
# Unsupported architectures:
"alpha")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
*)
# who knows?
......@@ -115,7 +116,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -2,6 +2,8 @@ default_mirror http://old-releases.ubuntu.com/ubuntu
mirror_style release
download_style apt
LIBC=libc6
work_out_debs () {
required="base-files base-passwd bash bsdutils coreutils libacl1 libattr1 debconf debconf-i18n liblocale-gettext-perl libtext-iconv-perl libtext-wrapi18n-perl libtext-charwidth-perl debianutils diff dpkg dselect libblkid1 e2fsprogs e2fslibs libcomerr2 libss2 libuuid1 findutils grep gzip hostname libcap1 libc6 libdb1-compat libdb3 libncurses5 libnewt0.51 libpam-modules libpam-runtime libpam0g libpopt0 login makedev mawk modutils mount ncurses-base ncurses-bin passwd perl-base procps sed slang1a-utf8 lsb-base initscripts sysvinit sysv-rc tar util-linux zlib1g whiptail libgcc1 gcc-3.3-base libstdc++5"
......@@ -15,8 +17,6 @@ work_out_debs () {
echo "$3" | tr ' ' '\n' | sed "s/^$1$/$2/" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"i386")
required="$required libc6-i686"
......@@ -110,7 +110,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
......@@ -2,6 +2,11 @@ default_mirror http://old-releases.ubuntu.com/ubuntu
mirror_style release
download_style apt
LIBC=libc6
if [ "$ARCH" = "alpha" ] || [ "$ARCH" = "ia64" ]; then
LIBC="libc6.1"
fi
work_out_debs () {
required="base-files base-passwd bash bsdutils build-essential coreutils debianutils diff dpkg dselect e2fslibs e2fsprogs fakeroot findutils gcc-3.3-base grep gzip hostname initscripts libacl1 libattr1 libblkid1 libc6 libcap1 libcomerr2 libdb1-compat libdb3 libgcc1 libncurses5 libpam-modules libpam-runtime libpam0g libss2 libstdc++5 libuuid1 login lsb-base mawk mount ncurses-base ncurses-bin perl-base sed slang1a-utf8 sysv-rc sysvinit tar util-linux zlib1g"
......@@ -15,8 +20,6 @@ work_out_debs () {
echo "$3" | tr ' ' '\n' | sed "s/^$1$/$2/" | tr '\n' ' '
}
LIBC6=libc6
case $ARCH in
"amd64")
;;
......@@ -29,12 +32,10 @@ work_out_debs () {
"alpha")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
"ia64")
required="$(subst_package "libc6" "libc6.1" "$required")"
base="$(subst_package "libc6-dev" "libc6.1-dev" "$base")"
LIBC6="libc6.1"
;;
*)
# who knows?
......@@ -115,7 +116,7 @@ second_stage_install () {
fi
p; progress $baseprog $bases INSTCORE "Installing core packages" #4
x_core_install $LIBC6
x_core_install $LIBC
p; progress $baseprog $bases INSTCORE "Installing core packages" #5
x_core_install perl-base
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment