Commit eb769365 authored by Thomas Goirand's avatar Thomas Goirand

Fixed compat option for newer qemu.

parent b408a83a
......@@ -417,11 +417,11 @@ if [ "${AUTOMATIC_RESIZE}" = "yes" ] ; then
install-mbr ${AMI_NAME}
fi
#QEMU_VERSION=`qemu-img --help | head -n 1 | cut -d" " -f3 | cut -d"," -f1`
#if dpkg --compare-versions ${QEMU_VERSION} gt 1.0 ; then
# OTHER_QEMU_IMG_OPTIONS=" -O compat=0.10"
#else
QEMU_VERSION=`qemu-img --help | head -n 1 | cut -d" " -f3 | cut -d"," -f1`
if dpkg --compare-versions ${QEMU_VERSION} gt 1.0 ; then
OTHER_QEMU_IMG_OPTIONS=" -o compat=0.10"
else
OTHER_QEMU_IMG_OPTIONS=""
#fi
fi
qemu-img convert -c -f raw ${AMI_NAME}${OTHER_QEMU_IMG_OPTIONS} -O qcow2 ${QCOW2_NAME}
openstack-debian-images (1.1) unstable; urgency=medium
* Fixed compat option for newer qemu.
-- Thomas Goirand <zigo@debian.org> Fri, 21 Nov 2014 13:48:26 +0800
openstack-debian-images (1.0) unstable; urgency=medium
* Fixed the sudoers file to support the --login option. (Closes: #766234)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment