New upstream. Fix #787090 #785200 #771626

parent 36e6270c
openvpn (2.3.7-1) unstable; urgency=medium
* New upstream version
* Add --no-block to if-up.d script to avoid hanging boot on
interfaces with openvpn instances. (Closes: #787090, #785200)
* Add ProtectSystem=yes to systemd's service file. (Closes: #771626)
-- Alberto Gonzalez Iniesta <agi@inittab.org> Wed, 01 Jul 2015 13:19:26 +0200
openvpn (2.3.5-1) unstable; urgency=medium
* New upstream release. Removed patches applied upstream:
......
......@@ -13,7 +13,7 @@ if [ -n "$IF_OPENVPN" ]; then
for vpn in $IF_OPENVPN; do
## check systemd present
if [ -d $SYSTEMD ]; then
$SYSTEMCTL start openvpn@$vpn
$SYSTEMCTL --no-block start openvpn@$vpn
else
$OPENVPN_INIT start $vpn
fi
......
......@@ -11,6 +11,7 @@ RemainAfterExit=yes
ExecStart=/bin/true
ExecReload=/bin/true
WorkingDirectory=/etc/openvpn
ProtectSystem=yes
[Install]
WantedBy=multi-user.target
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment