You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

control 6.0 KiB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Source: apt
  2. Section: admin
  3. Priority: important
  4. Maintainer: APT Development Team <deity@lists.debian.org>
  5. Uploaders: Michael Vogt <mvo@debian.org>,
  6. Julian Andres Klode <jak@debian.org>,
  7. David Kalnischkies <donkult@debian.org>
  8. Rules-Requires-Root: no
  9. Standards-Version: 4.1.1
  10. Build-Depends: cmake (>= 3.4),
  11. debhelper-compat (= 12),
  12. docbook-xml,
  13. docbook-xsl,
  14. dpkg-dev (>= 1.17.14),
  15. g++ (>= 4:7),
  16. gettext (>= 0.12),
  17. googletest <!nocheck> | libgtest-dev <!nocheck>,
  18. libbz2-dev,
  19. libdb-dev,
  20. libgnutls28-dev (>= 3.4.6),
  21. liblz4-dev (>= 0.0~r126),
  22. liblzma-dev,
  23. libseccomp-dev [amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el s390x hppa powerpc powerpcspe ppc64 x32],
  24. libudev-dev [linux-any],
  25. libzstd-dev (>= 1.0),
  26. ninja-build,
  27. pkg-config,
  28. po4a (>= 0.34-2),
  29. triehash,
  30. xsltproc,
  31. zlib1g-dev
  32. Build-Depends-Indep: doxygen, graphviz, w3m
  33. Vcs-Git: https://salsa.debian.org/apt-team/apt.git
  34. Vcs-Browser: https://salsa.debian.org/apt-team/apt
  35. Package: apt
  36. Architecture: any
  37. Depends: adduser,
  38. gpgv | gpgv2 | gpgv1,
  39. libapt-pkg6.0 (>= ${binary:Version}),
  40. ${apt:keyring},
  41. ${misc:Depends},
  42. ${shlibs:Depends}
  43. Replaces: apt-transport-https (<< 1.5~alpha4~), apt-utils (<< 1.3~exp2~)
  44. Breaks: apt-transport-https (<< 1.5~alpha4~),
  45. apt-utils (<< 1.3~exp2~),
  46. aptitude (<< 0.8.10)
  47. Provides: apt-transport-https (= ${binary:Version})
  48. Recommends: ca-certificates
  49. Suggests: apt-doc,
  50. aptitude | synaptic | wajig,
  51. dpkg-dev (>= 1.17.2),
  52. gnupg | gnupg2 | gnupg1,
  53. powermgmt-base
  54. Description: commandline package manager
  55. This package provides commandline tools for searching and
  56. managing as well as querying information about packages
  57. as a low-level access to all features of the libapt-pkg library.
  58. .
  59. These include:
  60. * apt-get for retrieval of packages and information about them
  61. from authenticated sources and for installation, upgrade and
  62. removal of packages together with their dependencies
  63. * apt-cache for querying available information about installed
  64. as well as installable packages
  65. * apt-cdrom to use removable media as a source for packages
  66. * apt-config as an interface to the configuration settings
  67. * apt-key as an interface to manage authentication keys
  68. Package: libapt-pkg6.0
  69. Architecture: any
  70. Multi-Arch: same
  71. Priority: optional
  72. Pre-Depends: ${misc:Pre-Depends}
  73. Depends: ${misc:Depends}, ${shlibs:Depends}
  74. Breaks: appstream (<< 0.9.0-3~), apt (<< 1.6~), aptitude (<< 0.8.9), libapt-inst1.5 (<< 0.9.9~)
  75. Recommends: apt (>= ${binary:Version})
  76. Section: libs
  77. Provides: libapt-pkg (= ${binary:Version})
  78. Description: package management runtime library
  79. This library provides the common functionality for searching and
  80. managing packages as well as information about packages.
  81. Higher-level package managers can depend upon this library.
  82. .
  83. This includes:
  84. * retrieval of information about packages from multiple sources
  85. * retrieval of packages and all dependent packages
  86. needed to satisfy a request either through an internal
  87. solver or by interfacing with an external one
  88. * authenticating the sources and validating the retrieved data
  89. * installation and removal of packages in the system
  90. * providing different transports to retrieve data over cdrom, ftp,
  91. http(s), rsh as well as an interface to add more transports like
  92. tor+http(s) (apt-transport-tor).
  93. Package: libapt-inst3.0
  94. Architecture: any
  95. Multi-Arch: same
  96. Priority: optional
  97. Pre-Depends: ${misc:Pre-Depends}
  98. Depends: ${misc:Depends}, ${shlibs:Depends}
  99. Section: libs
  100. Provides: libapt-inst (= ${binary:Version})
  101. Description: deb package format runtime library
  102. This library provides methods to query and extract information
  103. from deb packages. This includes the control data and the package
  104. file content.
  105. Package: apt-doc
  106. Architecture: all
  107. Priority: optional
  108. Depends: ${misc:Depends}
  109. Section: doc
  110. Description: documentation for APT
  111. This package contains the user guide and offline guide for various
  112. APT tools which are provided in a html and a text-only version.
  113. Package: libapt-pkg-dev
  114. Architecture: any
  115. Multi-Arch: same
  116. Priority: optional
  117. Pre-Depends: ${misc:Pre-Depends}
  118. Depends: libapt-inst (= ${binary:Version}),
  119. libapt-pkg (= ${binary:Version}),
  120. zlib1g-dev,
  121. ${misc:Depends}
  122. Section: libdevel
  123. Description: development files for APT's libapt-pkg and libapt-inst
  124. This package contains the header files and libraries for
  125. developing with APT's libapt-pkg Debian package manipulation
  126. library and the libapt-inst deb/tar/ar library.
  127. Package: libapt-pkg-doc
  128. Architecture: all
  129. Priority: optional
  130. Depends: ${misc:Depends}
  131. Section: doc
  132. Description: documentation for APT development
  133. This package contains documentation for development of the APT
  134. Debian package manipulation program and its libraries.
  135. .
  136. This includes the source code documentation generated by doxygen
  137. in html format.
  138. Package: apt-utils
  139. Architecture: any
  140. Depends: apt (= ${binary:Version}),
  141. libapt-inst3.0 (>= ${binary:Version}),
  142. ${misc:Depends},
  143. ${shlibs:Depends}
  144. Description: package management related utility programs
  145. This package contains some less used commandline utilities related
  146. to package management with APT.
  147. .
  148. * apt-extracttemplates is used by debconf to prompt for configuration
  149. questions before installation.
  150. * apt-ftparchive is used to create Packages and other index files
  151. needed to publish an archive of Debian packages
  152. * apt-sortpkgs is a Packages/Sources file normalizer.
  153. Package: apt-transport-https
  154. Architecture: all
  155. Multi-Arch: foreign
  156. Depends: apt (>= 1.5~alpha4), ${misc:Depends}
  157. Priority: optional
  158. Section: oldlibs
  159. Description: transitional package for https support
  160. This is a dummy transitional package - https support has been moved into
  161. the apt package in 1.5. It can be safely removed.