You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

test-bug-591882-conkeror 4.1 KiB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. #!/bin/sh
  2. set -e
  3. TESTDIR="$(readlink -f "$(dirname "$0")")"
  4. . "$TESTDIR/framework"
  5. setupenvironment
  6. configarchitecture "i386"
  7. setupaptarchive
  8. UPGRADEFAIL="Reading package lists...
  9. Building dependency tree...
  10. Calculating upgrade...
  11. The following packages will be REMOVED:
  12. conkeror libdatrie0 libkrb53 libxcb-xlib0 xulrunner-1.9
  13. The following NEW packages will be installed:
  14. gcc-4.4-base libavahi-client3 libavahi-common-data libavahi-common3 libc-bin
  15. libdatrie1 libdb4.7 libdb4.8 libdbus-1-3 libgssapi-krb5-2 libjasper1
  16. libk5crypto3 libkrb5-3 libkrb5support0 liblzma2 libpam-modules libpam0g
  17. libuuid1 libxcb-atom1 libxcb-aux0 libxcb-event1 libxml2 passwd
  18. sensible-utils shared-mime-info xz-utils
  19. The following packages will be upgraded:
  20. coreutils debconf debconf-i18n debianutils defoma dpkg file fontconfig
  21. fontconfig-config libacl1 libatk1.0-0 libattr1 libbz2-1.0 libc6 libcairo2
  22. libcomerr2 libcups2 libexpat1 libfontconfig1 libfreetype6 libgcc1
  23. libgcrypt11 libgdbm3 libglib2.0-0 libgnutls26 libgpg-error0 libgtk2.0-0
  24. libgtk2.0-common libhunspell-1.2-0 libice6 libjpeg62 libkeyutils1
  25. liblocale-gettext-perl libmagic1 libncurses5 libnewt0.52 libnspr4-0d
  26. libnss3-1d libpango1.0-0 libpango1.0-common libpcre3 libpixman-1-0
  27. libpng12-0 libpopt0 libselinux1 libslang2 libsm6 libsqlite3-0
  28. libstartup-notification0 libstdc++6 libtasn1-3 libtext-charwidth-perl
  29. libtext-iconv-perl libtext-wrapi18n-perl libthai-data libthai0 libtiff4
  30. libx11-6 libx11-data libxau6 libxcb-render-util0 libxcb-render0 libxcb1
  31. libxcomposite1 libxcursor1 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxft2
  32. libxi6 libxinerama1 libxrandr2 libxrender1 libxt6 lsb-base ncurses-bin perl
  33. perl-base perl-modules readline-common sed ttf-dejavu-core ucf whiptail
  34. x11-common zlib1g
  35. 87 upgraded, 26 newly installed, 5 to remove and 0 not upgraded.
  36. Need to get 0 B/54.4 MB of archives.
  37. After this operation, 12.4 MB of additional disk space will be used.
  38. E: Trivial Only specified but this is not a trivial operation."
  39. UPGRADESUCCESS="Reading package lists...
  40. Building dependency tree...
  41. Calculating upgrade...
  42. The following packages will be REMOVED:
  43. libdatrie0 libkrb53 libxcb-xlib0 xulrunner-1.9
  44. The following NEW packages will be installed:
  45. gcc-4.4-base libasound2 libavahi-client3 libavahi-common-data
  46. libavahi-common3 libc-bin libdatrie1 libdb4.7 libdb4.8 libdbus-1-3
  47. libgssapi-krb5-2 libjasper1 libk5crypto3 libkrb5-3 libkrb5support0 liblzma2
  48. libmozjs2d libpam-modules libpam0g libreadline6 libuuid1 libxcb-atom1
  49. libxcb-aux0 libxcb-event1 libxml2 passwd sensible-utils shared-mime-info
  50. xulrunner-1.9.1 xz-utils
  51. The following packages will be upgraded:
  52. conkeror coreutils debconf debconf-i18n debianutils defoma dpkg file
  53. fontconfig fontconfig-config libacl1 libatk1.0-0 libattr1 libbz2-1.0 libc6
  54. libcairo2 libcomerr2 libcups2 libexpat1 libfontconfig1 libfreetype6 libgcc1
  55. libgcrypt11 libgdbm3 libglib2.0-0 libgnutls26 libgpg-error0 libgtk2.0-0
  56. libgtk2.0-common libhunspell-1.2-0 libice6 libjpeg62 libkeyutils1
  57. liblocale-gettext-perl libmagic1 libncurses5 libnewt0.52 libnspr4-0d
  58. libnss3-1d libpango1.0-0 libpango1.0-common libpcre3 libpixman-1-0
  59. libpng12-0 libpopt0 libselinux1 libslang2 libsm6 libsqlite3-0
  60. libstartup-notification0 libstdc++6 libtasn1-3 libtext-charwidth-perl
  61. libtext-iconv-perl libtext-wrapi18n-perl libthai-data libthai0 libtiff4
  62. libx11-6 libx11-data libxau6 libxcb-render-util0 libxcb-render0 libxcb1
  63. libxcomposite1 libxcursor1 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxft2
  64. libxi6 libxinerama1 libxrandr2 libxrender1 libxt6 lsb-base ncurses-bin perl
  65. perl-base perl-modules readline-common sed ttf-dejavu-core ucf whiptail
  66. x11-common zlib1g
  67. 88 upgraded, 30 newly installed, 4 to remove and 0 not upgraded.
  68. Need to get 0 B/62.9 MB of archives.
  69. After this operation, 36.0 MB of additional disk space will be used.
  70. E: Trivial Only specified but this is not a trivial operation."
  71. # Test that the old behavior can be restored with the option
  72. testfailureequal "$UPGRADEFAIL" aptget dist-upgrade --trivial-only -o pkgProblemResolver::FixByInstall=0
  73. testfailureequal "$UPGRADESUCCESS" aptget dist-upgrade --trivial-only #-o pkgProblemResolver::FixByInstall=0