Browse Source

debian: Drop outdated stuff

The README.source is not usable anymore, and the Build-Conflicts
andd Breaks/Replaces are not needed anymore.
debian/1.8.y
Julian Andres Klode 7 years ago
parent
commit
20d2f4a4f1
  1. 6
      debian/README.source
  2. 3
      debian/control

6
debian/README.source

@ -1,6 +0,0 @@
Build this package with:
$ debian/rules arch-build
or
$ DEB_BUILD_PROG_OPTS="-S" debian/rules arch-build
make sure you have the pre-build-depds in README.arch installed

3
debian/control

@ -12,7 +12,6 @@ Build-Depends: dpkg-dev (>= 1.17.14), debhelper (>= 9.20160709~), libdb-dev,
xsltproc, docbook-xsl, docbook-xml, po4a (>= 0.34-2),
cmake (>= 3.4), pkg-config, libgtest-dev <!nocheck>, dh-systemd
Build-Depends-Indep: doxygen, w3m, graphviz
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Git: https://anonscm.debian.org/git/apt/apt.git
Vcs-Browser: https://anonscm.debian.org/git/apt/apt.git
Testsuite: autopkgtest
@ -20,8 +19,6 @@ Testsuite: autopkgtest
Package: apt
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${apt:keyring}, gpgv | gpgv2 | gpgv1, adduser
Replaces: manpages-pl (<< 20060617-3~), manpages-it (<< 2.80-4~), sun-java6-jdk (>> 0), sun-java5-jdk (>> 0), openjdk-6-jdk (<< 6b24-1.11-0ubuntu1~), bash-completion (<< 1:2.1-4.2+fakesync1), apt-utils (<< 1.3~exp2~)
Breaks: manpages-pl (<< 20060617-3~), manpages-it (<< 2.80-4~), sun-java6-jdk (>> 0), sun-java5-jdk (>> 0), openjdk-6-jdk (<< 6b24-1.11-0ubuntu1~), apt-utils (<< 1.3~exp2~)
Recommends: gnupg | gnupg2 | gnupg1
Suggests: aptitude | synaptic | wajig, dpkg-dev (>= 1.17.2), apt-doc, python-apt, powermgmt-base
Description: commandline package manager

Loading…
Cancel
Save