Browse Source

Added lintian override of 'must depend on python.

debian/1.8.y
Eugene V. Lyubimkin 13 years ago
parent
commit
acbd8c84cf
  1. 4
      debian/changelog
  2. 3
      debian/rules
  3. 3
      share/lintian-overrides

4
debian/changelog

@ -22,6 +22,10 @@ apt (0.7.17) unstable; urgency=low
'maintainer-script-ignores-error'.
* dselect/makefile:
- Removed unneeded 'LOCAL' entry. This allows cleaning rule to run smoothly.
* share/lintian-overrides:
- Added with override of 'apt must depend on python'. Script 'apt-mark'
needs apt-python for working and checks this on fly. We don't want
python in most cases.
-- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Fri, 24 Oct 2008 23:45:17 +0300

3
debian/rules

@ -217,6 +217,9 @@ apt: build debian/shlibs.local
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
# head -n 500 ChangeLog > debian/ChangeLog
# copy lintian override
cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
# make rosetta happy and remove pot files in po/ (but leave stuff
# in po/domains/* untouched) and cp *.po into each domain dir
rm -f build/po/*.pot

3
share/lintian-overrides

@ -0,0 +1,3 @@
# apt-mark is rarely used auxiliary script, we don't want to depend on
# python-apt only for it.
apt binary: python-script-but-no-python-dep ./usr/bin/apt-mark
Loading…
Cancel
Save