290 Commits (3a0681754f97a66705cf69869751c5ac5d2c307c)

Author SHA1 Message Date
  Julian Andres Klode 6685536344 Build with cmake+ninja instead of cmake+make 3 years ago
  David Kalnischkies c6c6c8fe93 set our two libapt libraries to prio:optional 3 years ago
  Julian Andres Klode 4de4200ec2 apt-pkg: Add support for zstd 3 years ago
  Julian Andres Klode 0f16676cd7 Point people to salsa.d.o instead of anonscm.d.o for git 3 years ago
  Julian Andres Klode 8aae95a7f8 Drop obsolete Suggests on python-apt 3 years ago
  Julian Andres Klode 5f6da84bb9 Run wrap-and-sort 3 years ago
  Julian Andres Klode e15d2e7044 Add Breaks: aptitude (<< 0.8.10) for gzip method removal 3 years ago
  Julian Andres Klode 32b39bf5c9 [amend] Use a versioned breaks for a-t-https in apt 3 years ago
  Julian Andres Klode 6857ce09df Add ${misc:Depends} to apt-transport-https depends 3 years ago
  Julian Andres Klode afe3cd6ef1 Re-introduce a transitional apt-transport-https 3 years ago
  Julian Andres Klode 20cb61e6d8 debian: Bump Standards-Version to 4.1.1 3 years ago
  Julian Andres Klode cf10563c87 debian: Set Rules-Requires-Root: no 3 years ago
  Julian Andres Klode 32bcbd73e0 Sandbox methods with seccomp-BPF; except cdrom, gpgv, rsh 3 years ago
  Julian Andres Klode 5e770a07c8 Drop curl method and apt-transport-https package 3 years ago
  Julian Andres Klode 6d44f502d1 Drop obsolute Testsuite: autopkgtest header 3 years ago
  Julian Andres Klode 710ae24957 Drop obsolete dh-systemd build-dep 3 years ago
  Julian Andres Klode 8bf1c394f4 Bump Standards-Version to 4.1.0 3 years ago
  Julian Andres Klode 96b4580561 Directly link against libudev on Linux systems 3 years ago
  Julian Andres Klode f63b3e01e4 Handle GCC 7 std::string operator ABI break 3 years ago
  David Kalnischkies 49a81c237e remove reference to a-t-debtorrent in description 3 years ago
  Julian Andres Klode c6a428e4d1 Switch to 'http' as the default https method 3 years ago
  Julian Andres Klode 55db48d5a9 Build-Depend on debhelper (>= 10) to shut up lintian 3 years ago
  Julian Andres Klode 47e66f6536 Bump Standards-Version (and wrap-and-sort a bit) 3 years ago
  Julian Andres Klode 22ee196fb9 Demote gnupg to Suggests 3 years ago
  Julian Andres Klode 617e315a7e Have apt Recommend ca-certificates 3 years ago
  Julian Andres Klode 2851ec6cf0 methods: Add HTTPS support to http method, using GnuTLS 3 years ago
  David Kalnischkies 0123ce7171 follow the googletest merge in build-depends 4 years ago
  David Kalnischkies f9c2f3e972 re-add apt breaks/replaces apt-utils (<< 1.3~exp2~) 4 years ago
  Julian Andres Klode 29742f9563 debian: Run wrap-and-sort 4 years ago
  Julian Andres Klode 20d2f4a4f1 debian: Drop outdated stuff 4 years ago
  Julian Andres Klode 113eaa2921 debian: Switch to debhelper 10 4 years ago
  David Kalnischkies 19fdf93d73 add the gpg-classic variant to the gpgv/gnupg or-group 4 years ago
  Julian Andres Klode 4030a6698e Change anonscm.d.o links to /git/apt/apt.git and https 4 years ago
  Julian Andres Klode 4924e4686c CMake: Bump minimum required version to 3.4.0 4 years ago
  Julian Andres Klode 8a76b2bdc2 Build-depend on pkg-config 4 years ago
  Julian Andres Klode e825742bbb CMake: debian: Switch packaging over to CMake and dh 9 4 years ago
  Julian Andres Klode 2b54bc754e debian/control: Use versioned provides for same-ver library deps 4 years ago
  David Kalnischkies a523cb7f26 add myself to Uploaders 4 years ago
  Nicolas Le Cam 6de1059e14 Add a apt suggests powermgmt-base 4 years ago
  David Kalnischkies ab07af708e move 'dump' solver from apt-utils to apt package 4 years ago
  David Kalnischkies 30896d0137 use https instead of git for Vcs-Git 5 years ago
  David Kalnischkies 150f143167 no-change bump of Standards-Version to 3.9.8 5 years ago
  David Kalnischkies 87d468fe35 move gnupg|gnupg2 from apt Depends to Recommends 5 years ago
  Michael Vogt 14669d4b95 Use systemd.timer instead of a cron job 5 years ago
  Julian Andres Klode 607bab3fe8 debian/control: Set Standards-Version to 3.9.7 5 years ago
  Julian Andres Klode 1051eb8359 Drop the g++ build-dep, transition is done 5 years ago
  Julian Andres Klode 1dbd5b4609 Version the build-depends on liblz4-dev to >= 0.0~r126 5 years ago
  Julian Andres Klode 68b57083e6 Bump dpkg-dev and debhelper build-dep to make lintian happy 5 years ago
  Julian Andres Klode 280a9f18d6 Do not break apt-file (<< 3.0~exp1~), 2.X works fine 5 years ago
  Julian Andres Klode 79adeafe8c Break apt-file (<< 3.0~exp1~) 5 years ago