You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

153 lines
5.4 KiB

  1. Source: apt
  2. Section: admin
  3. Priority: important
  4. Maintainer: Andreas Messer <andi@bastelmap.de>
  5. Rules-Requires-Root: no
  6. Standards-Version: 4.1.1
  7. Build-Depends: cmake (>= 3.4),
  8. debhelper-compat (= 12),
  9. docbook-xml,
  10. docbook-xsl,
  11. dpkg-dev (>= 1.17.14),
  12. gettext (>= 0.12),
  13. googletest <!nocheck> | libgtest-dev <!nocheck>,
  14. libbz2-dev,
  15. libdb-dev,
  16. libgnutls28-dev (>= 3.4.6),
  17. libgcrypt20-dev,
  18. liblz4-dev (>= 0.0~r126),
  19. liblzma-dev,
  20. libseccomp-dev (>= 2.4.2) [amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el s390x hppa powerpc powerpcspe ppc64 x32],
  21. libudev-dev [linux-any],
  22. libzstd-dev (>= 1.0),
  23. ninja-build,
  24. pkg-config,
  25. po4a (>= 0.34-2),
  26. triehash,
  27. xsltproc,
  28. zlib1g-dev
  29. Build-Depends-Indep: doxygen, graphviz, w3m
  30. Vcs-Git: https://git.devuan.org/devuan/apt.git
  31. Vcs-Browser: https://git.devuan.org/devuan/apt
  32. Origin: Devuan
  33. Package: apt
  34. Architecture: any
  35. Depends: adduser,
  36. gpgv | gpgv2 | gpgv1,
  37. libapt-pkg6.0 (>= ${binary:Version}),
  38. ${apt:keyring},
  39. ${misc:Depends},
  40. ${shlibs:Depends}
  41. Replaces: apt-transport-https (<< 1.5~alpha4~), apt-utils (<< 1.3~exp2~)
  42. Breaks: apt-transport-https (<< 1.5~alpha4~),
  43. apt-utils (<< 1.3~exp2~),
  44. aptitude (<< 0.8.10)
  45. Provides: apt-transport-https (= ${binary:Version})
  46. Recommends: ca-certificates
  47. Suggests: apt-doc,
  48. aptitude | synaptic | wajig,
  49. dpkg-dev (>= 1.17.2),
  50. gnupg | gnupg2 | gnupg1,
  51. powermgmt-base
  52. Description: commandline package manager
  53. This package provides commandline tools for searching and
  54. managing as well as querying information about packages
  55. as a low-level access to all features of the libapt-pkg library.
  56. .
  57. These include:
  58. * apt-get for retrieval of packages and information about them
  59. from authenticated sources and for installation, upgrade and
  60. removal of packages together with their dependencies
  61. * apt-cache for querying available information about installed
  62. as well as installable packages
  63. * apt-cdrom to use removable media as a source for packages
  64. * apt-config as an interface to the configuration settings
  65. * apt-key as an interface to manage authentication keys
  66. Package: libapt-pkg6.0
  67. Architecture: any
  68. Multi-Arch: same
  69. Priority: optional
  70. Pre-Depends: ${misc:Pre-Depends}
  71. Depends: ${misc:Depends}, ${shlibs:Depends}
  72. Breaks: appstream (<< 0.9.0-3~), apt (<< 1.6~), aptitude (<< 0.8.9), libapt-inst1.5 (<< 0.9.9~)
  73. Recommends: apt (>= ${binary:Version})
  74. Section: libs
  75. Provides: libapt-pkg (= ${binary:Version})
  76. Description: package management runtime library
  77. This library provides the common functionality for searching and
  78. managing packages as well as information about packages.
  79. Higher-level package managers can depend upon this library.
  80. .
  81. This includes:
  82. * retrieval of information about packages from multiple sources
  83. * retrieval of packages and all dependent packages
  84. needed to satisfy a request either through an internal
  85. solver or by interfacing with an external one
  86. * authenticating the sources and validating the retrieved data
  87. * installation and removal of packages in the system
  88. * providing different transports to retrieve data over cdrom, ftp,
  89. http(s), rsh as well as an interface to add more transports like
  90. tor+http(s) (apt-transport-tor).
  91. Package: apt-doc
  92. Architecture: all
  93. Priority: optional
  94. Depends: ${misc:Depends}
  95. Section: doc
  96. Description: documentation for APT
  97. This package contains the user guide and offline guide for various
  98. APT tools which are provided in a html and a text-only version.
  99. Package: libapt-pkg-dev
  100. Architecture: any
  101. Multi-Arch: same
  102. Priority: optional
  103. Pre-Depends: ${misc:Pre-Depends}
  104. Depends: libapt-pkg (= ${binary:Version}),
  105. zlib1g-dev,
  106. ${misc:Depends}
  107. Section: libdevel
  108. Description: development files for APT's libapt-pkg and libapt-inst
  109. This package contains the header files and libraries for
  110. developing with APT's libapt-pkg Debian package manipulation
  111. library and the libapt-inst deb/tar/ar library.
  112. Package: libapt-pkg-doc
  113. Architecture: all
  114. Priority: optional
  115. Depends: ${misc:Depends}
  116. Section: doc
  117. Description: documentation for APT development
  118. This package contains documentation for development of the APT
  119. Debian package manipulation program and its libraries.
  120. .
  121. This includes the source code documentation generated by doxygen
  122. in html format.
  123. Package: apt-utils
  124. Architecture: any
  125. Depends: apt (= ${binary:Version}),
  126. ${misc:Depends},
  127. ${shlibs:Depends}
  128. Description: package management related utility programs
  129. This package contains some less used commandline utilities related
  130. to package management with APT.
  131. .
  132. * apt-extracttemplates is used by debconf to prompt for configuration
  133. questions before installation.
  134. * apt-ftparchive is used to create Packages and other index files
  135. needed to publish an archive of Debian packages
  136. * apt-sortpkgs is a Packages/Sources file normalizer.
  137. Package: apt-transport-https
  138. Architecture: all
  139. Multi-Arch: foreign
  140. Depends: apt (>= 1.5~alpha4), ${misc:Depends}
  141. Priority: optional
  142. Section: oldlibs
  143. Description: transitional package for https support
  144. This is a dummy transitional package - https support has been moved into
  145. the apt package in 1.5. It can be safely removed.