You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

251 lines
12 KiB

  1. #!/bin/sh
  2. set -e
  3. TESTDIR="$(readlink -f "$(dirname "$0")")"
  4. . "$TESTDIR/framework"
  5. setupenvironment
  6. configarchitecture 'i386'
  7. # we need to insert a package into "unstable" so that a Release file is
  8. # create for the test
  9. insertpackage 'wheezy' 'build-essential' 'all' '1.0'
  10. # a "normal" package with source and binary
  11. insertpackage 'unstable' 'foo' 'all' '2.0'
  12. insertsource 'unstable' 'foo' 'all' '2.0'
  13. insertpackage 'unstable' 'foo-common' 'all' '2.0' 'Source: foo (2.0)'
  14. insertpackage 'experimental' 'foo' 'all' '5' 'Depends: foo-common (= 5)'
  15. insertpackage 'experimental' 'foo-common' 'all' '5' 'Source: foo (5)'
  16. insertsource 'experimental' 'foo-source' 'all' '42' 'Build-Depends: foo (= 5), baz'
  17. # binary packages with Source-field
  18. insertpackage 'unstable,testing' 'bin' 'i386' '3-2+b1' 'Source: bin (3-2)'
  19. insertsource 'unstable,testing' 'bin' 'any' '3-2'
  20. insertpackage 'stable' 'bin' 'i386' '2-2+b1' 'Source: bin-backport (2-2)'
  21. insertsource 'stable' 'bin-backport' 'any' '2-2'
  22. # its possible to have multiple src versions in the sources file, ensure
  23. # to pick the correct one in this case (bts #731853)
  24. insertsource 'stable' 'foo' 'all' '1.5'
  25. insertsource 'stable' 'foo' 'all' '0.5'
  26. insertpackage 'stable' 'foo' 'all' '1.0'
  27. insertsource 'stable' 'foo' 'all' '1.0'
  28. # these packages exists only as sources, add two versions to ensure that
  29. # apt will pick the higher version number (bts #731853)
  30. insertsource 'wheezy' 'foo' 'all' '0.0.1'
  31. insertsource 'wheezy' 'foo' 'all' '0.1'
  32. # the order of these versions is chosen to ensure that
  33. # * apt will pick the one in the correct release, despite a higher version coming later and
  34. # * apt will pick the highest version in a release, despite a lower version coming later.
  35. # (bts #746412)
  36. insertsource 'stable' 'baz' 'all' '1.0'
  37. insertsource 'unstable' 'baz' 'all' '2.0'
  38. insertsource 'unstable' 'baz' 'all' '1.5'
  39. insertpackage 'unstable' 'baz' 'all' '2.0'
  40. insertpackage 'experimental' 'baz' 'all' '5.0'
  41. # ensure we really have the situation we wanted (first 2.0 is foo above)
  42. testequal 'Version: 2.0
  43. Version: 3-2
  44. Version: 2.0
  45. Version: 1.5' grep '^Version:' aptarchive/dists/unstable/main/source/Sources
  46. insertsource 'stable' 'bar' 'any' '1.1' 'Vcs-Browser: https://anonscm.debian.org/cgit/bar/bar.git
  47. Vcs-Git: git://anonscm.debian.org/bar/bar.git -b debian/experimental'
  48. setupaptarchive
  49. APTARCHIVE=$(readlink -f ./aptarchive)
  50. # normal operation gets highest version number
  51. HEADER='Reading package lists...'
  52. DOWNLOAD1="Need to get 0 B/25 B of source archives.
  53. 'file://${APTARCHIVE}/foo_1.0.dsc' foo_1.0.dsc 11 SHA256:ed7c25c832596339bee13e4e7c45cf49f869b60d2bf57252f18191d75866c2a7
  54. 'file://${APTARCHIVE}/foo_1.0.tar.gz' foo_1.0.tar.gz 14 SHA256:f3da8c6ebc62c8ef2dae439a498dddcdacc1a07f45ff67ad12f44b6e2353c239"
  55. DOWNLOAD2="Need to get 0 B/25 B of source archives.
  56. 'file://${APTARCHIVE}/foo_2.0.dsc' foo_2.0.dsc 11 SHA256:0fcb803ffbeef26db884625aaf06e75f3eda5c994634980e7c20fd37ed1fc104
  57. 'file://${APTARCHIVE}/foo_2.0.tar.gz' foo_2.0.tar.gz 14 SHA256:ca9b0b828ca22372502af2b80f61f0bd9063910ece9fc34eeaf9d9e31aa8195a"
  58. DOWNLOAD3="Need to get 0 B/25 B of source archives.
  59. 'file://${APTARCHIVE}/baz_1.0.dsc' baz_1.0.dsc 11 SHA256:322245f56092b466801dda62d79c8687bba9724af6d16d450d655d29e41d3d7b
  60. 'file://${APTARCHIVE}/baz_1.0.tar.gz' baz_1.0.tar.gz 14 SHA256:0870bc73164ff5ba1f52153fdcb48e140137f9c7c122d57592cea136a57f73c0"
  61. DOWNLOAD4="Need to get 0 B/25 B of source archives.
  62. 'file://${APTARCHIVE}/baz_2.0.dsc' baz_2.0.dsc 11 SHA256:47d062d29070b3f592d1c8aed8c1e7913804bbb67ca1d64877c8219dac5e0420
  63. 'file://${APTARCHIVE}/baz_2.0.tar.gz' baz_2.0.tar.gz 14 SHA256:11c1b202c94a64ab6433d9f0ed5515fce1dc7b20e6bcf51cec9ef8b9455f5a41"
  64. testsuccessequal "$HEADER
  65. $DOWNLOAD2" apt source -q --print-uris foo
  66. testsuccessequal "$HEADER
  67. $DOWNLOAD2" apt source -q --print-uris foo foo
  68. getbuilddep() {
  69. echo 'Reading package lists...'
  70. if [ -n "$2" ]; then
  71. echo "$2"
  72. fi
  73. echo "${1} has no build depends.
  74. Reading package lists...
  75. Building dependency tree...
  76. The following NEW packages will be installed:
  77. build-essential
  78. 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
  79. Inst build-essential (1.0 wheezy [all])
  80. Conf build-essential (1.0 wheezy [all])"
  81. }
  82. testsuccessequal "$(getbuilddep 'foo')" apt build-dep foo -s
  83. # select by release: suite
  84. testsuccessequal "$HEADER
  85. Selected version '1.0' (stable) for foo
  86. $DOWNLOAD1" apt source -q --print-uris foo/stable
  87. testsuccessequal "$(getbuilddep 'foo' "Selected version '1.0' (stable) for foo")" apt build-dep foo/stable -s
  88. testsuccessequal "$HEADER
  89. Selected version '2.0' (unstable) for foo
  90. $DOWNLOAD2" apt source -q --print-uris foo/unstable
  91. testsuccessequal "$(getbuilddep 'foo' "Selected version '2.0' (unstable) for foo")" apt build-dep foo/unstable -s
  92. testsuccessequal "$HEADER
  93. Selected version '1.0' (stable) for foo
  94. $DOWNLOAD1" apt source -q --print-uris foo -t stable
  95. testsuccessequal "$(getbuilddep 'foo' "Selected version '1.0' (stable) for foo")" apt build-dep foo -t stable -s
  96. testsuccessequal "$HEADER
  97. Selected version '2.0' (unstable) for foo
  98. $DOWNLOAD2" apt source -q --print-uris foo -t unstable
  99. testsuccessequal "$(getbuilddep 'foo' "Selected version '2.0' (unstable) for foo")" apt build-dep foo -t unstable -s
  100. testsuccessequal "$HEADER
  101. Selected version '1.0' (stable) for baz
  102. $DOWNLOAD3" apt source -q --print-uris baz -t stable
  103. testsuccessequal "$(getbuilddep 'baz' "Selected version '1.0' (stable) for baz")" apt build-dep baz -t stable -s
  104. # select by release: codename
  105. testsuccessequal "$HEADER
  106. Selected version '2.0' (sid) for foo
  107. $DOWNLOAD2" apt source -q --print-uris foo/sid
  108. testsuccessequal "$(getbuilddep 'foo' "Selected version '2.0' (sid) for foo")" apt build-dep foo/sid -s
  109. testsuccessequal "$HEADER
  110. Selected version '2.0' (sid) for foo
  111. $DOWNLOAD2" apt source -q --print-uris foo -t sid
  112. testsuccessequal "$(getbuilddep 'foo' "Selected version '2.0' (sid) for foo")" apt build-dep foo -t sid -s
  113. testsuccessequal "$HEADER
  114. Selected version '2.0' (sid) for baz
  115. $DOWNLOAD4" apt source -q --print-uris baz -t sid
  116. testsuccessequal "$(getbuilddep 'baz' "Selected version '2.0' (sid) for baz")" apt build-dep baz -t sid -s
  117. # select by version
  118. testsuccessequal "$HEADER
  119. $DOWNLOAD1" apt source -q --print-uris foo=1.0
  120. testsuccessequal "$(getbuilddep 'foo')" apt build-dep foo=1.0 -s
  121. # select by release with no binary package (Bug#731102) but ensure to get
  122. # highest version
  123. DOWNLOAD01="Need to get 0 B/25 B of source archives.
  124. 'file://${APTARCHIVE}/foo_0.1.dsc' foo_0.1.dsc 11 SHA256:72af24b0290fe1d13a3e25fddd2633e43c87ff79d249bc850009e47bcce73565
  125. 'file://${APTARCHIVE}/foo_0.1.tar.gz' foo_0.1.tar.gz 14 SHA256:ec748ad88a71f98bfdc012e1a7632377d05fe3ebbf9c0922e0691fe4d79c0585"
  126. testsuccessequal "$HEADER
  127. Selected version '0.1' (wheezy) for foo
  128. $DOWNLOAD01" apt source -q --print-uris foo/wheezy
  129. testsuccessequal "$(getbuilddep 'foo' "Selected version '0.1' (wheezy) for foo")" apt build-dep foo/wheezy -s
  130. # unavailable one
  131. testfailureequal "$HEADER
  132. E: Can not find version '9.9-not-there' of package 'foo'
  133. E: Unable to find a source package for foo" apt source -q --print-uris foo=9.9-not-there
  134. testfailureequal "Reading package lists...
  135. E: Can not find version '9.9-not-there' of package 'foo'
  136. E: Unable to find a source package for foo=9.9-not-there" apt build-dep -s foo=9.9-not-there
  137. # version and release
  138. DOWNLOAD001="Need to get 0 B/29 B of source archives.
  139. 'file://${APTARCHIVE}/foo_0.0.1.dsc' foo_0.0.1.dsc 13 SHA256:649dfe03bbb70cebdfe7c6bf9036f9f2472510b8f52e823bdf5ade362ebaa76f
  140. 'file://${APTARCHIVE}/foo_0.0.1.tar.gz' foo_0.0.1.tar.gz 16 SHA256:ab7ba789d178362ecc808e49705e2338988a7f5b9410ec11a6c9555c017de907"
  141. testsuccessequal "$HEADER
  142. $DOWNLOAD001" apt source -q --print-uris -t unstable foo=0.0.1
  143. testsuccessequal "$(getbuilddep 'foo')" apt build-dep foo=0.0.1 -s
  144. testsuccessequal "$HEADER
  145. Need to get 0 B/25 B of source archives.
  146. Fetch source foo" apt source -q -s foo
  147. testsuccessequal "$(getbuilddep 'foo')" apt build-dep foo -s
  148. testfailureequal 'E: Must specify at least one package to fetch source for' apt source
  149. testfailureequal 'E: Must specify at least one package to check builddeps for' apt build-dep
  150. testsuccessequal "Reading package lists...
  151. NOTICE: 'bar' packaging is maintained in the 'Git' version control system at:
  152. git://anonscm.debian.org/bar/bar.git -b debian/experimental
  153. Please use:
  154. git clone git://anonscm.debian.org/bar/bar.git -b debian/experimental
  155. to retrieve the latest (possibly unreleased) updates to the package.
  156. Need to get 0 B/25 B of source archives.
  157. Fetch source bar" apt source bar -s
  158. testsuccessequal "$(getbuilddep 'bar')" apt build-dep bar -s
  159. testsuccessequal "$HEADER
  160. Need to get 0 B/25 B of source archives.
  161. Fetch source bin" apt source bin -s -q
  162. testsuccessequal "$(getbuilddep 'bin')" apt build-dep bin -s
  163. testsuccessequal "$HEADER
  164. Selected version '3-2' (unstable) for bin
  165. Need to get 0 B/25 B of source archives.
  166. Fetch source bin" apt source bin/unstable -s -q
  167. testsuccessequal "$(getbuilddep 'bin' "Selected version '3-2' (unstable) for bin")" apt build-dep bin/unstable -s
  168. testsuccessequal "$HEADER
  169. Picking 'bin-backport' as source package instead of 'bin'
  170. Selected version '2-2' (stable) for bin-backport
  171. Need to get 0 B/43 B of source archives.
  172. Fetch source bin-backport" apt source bin/stable -s -q
  173. testsuccessequal "$(getbuilddep 'bin-backport' "Picking 'bin-backport' as source package instead of 'bin'
  174. Selected version '2-2' (stable) for bin-backport")" apt build-dep bin/stable -s
  175. testsuccess apt install foo/experimental -s
  176. testfailure apt build-dep foo-source -s
  177. testsuccessequal "Reading package lists...
  178. Selected version '42' (experimental) for foo-source
  179. Reading package lists...
  180. Building dependency tree...
  181. Selected version '5' (experimental [all]) for 'foo' because of 'src:foo-source'
  182. Selected version '5' (experimental [all]) for 'foo-common' because of 'foo'
  183. The following NEW packages will be installed:
  184. baz build-essential foo foo-common
  185. 0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
  186. Inst baz (2.0 unstable [all])
  187. Inst build-essential (1.0 wheezy [all])
  188. Inst foo-common (5 experimental [all])
  189. Inst foo (5 experimental [all])
  190. Conf baz (2.0 unstable [all])
  191. Conf build-essential (1.0 wheezy [all])
  192. Conf foo-common (5 experimental [all])
  193. Conf foo (5 experimental [all])" apt build-dep foo-source/experimental -s
  194. testsuccessequal "Reading package lists...
  195. Selected version '42' (experimental) for foo-source
  196. Reading package lists...
  197. Building dependency tree...
  198. The following NEW packages will be installed:
  199. baz build-essential foo foo-common
  200. 0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
  201. Inst baz (5.0 experimental [all])
  202. Inst build-essential (1.0 wheezy [all])
  203. Inst foo-common (5 experimental [all])
  204. Inst foo (5 experimental [all])
  205. Conf baz (5.0 experimental [all])
  206. Conf build-essential (1.0 wheezy [all])
  207. Conf foo-common (5 experimental [all])
  208. Conf foo (5 experimental [all])" apt build-dep foo-source -t experimental -s
  209. # this checks that mentioning the source pkg baz has no influence on the binary package baz
  210. testsuccessequal "Reading package lists...
  211. Selected version '42' (experimental) for foo-source
  212. Selected version '2.0' (unstable) for baz
  213. baz has no build depends.
  214. Reading package lists...
  215. Building dependency tree...
  216. The following NEW packages will be installed:
  217. baz build-essential foo foo-common
  218. 0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
  219. Inst baz (5.0 experimental [all])
  220. Inst build-essential (1.0 wheezy [all])
  221. Inst foo-common (5 experimental [all])
  222. Inst foo (5 experimental [all])
  223. Conf baz (5.0 experimental [all])
  224. Conf build-essential (1.0 wheezy [all])
  225. Conf foo-common (5 experimental [all])
  226. Conf foo (5 experimental [all])" apt build-dep foo-source baz/unstable -t experimental -s