You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

57 lines
2.0 KiB

  1. #!/bin/sh
  2. set -e
  3. TESTDIR="$(readlink -f "$(dirname "$0")")"
  4. . "$TESTDIR/framework"
  5. setupenvironment
  6. configarchitecture 'amd64' 'i386'
  7. insertpackage 'unstable-mp' 'crda' 'i386,amd64' '1.1.1-1ubuntu4mp' 'Provides: wireless-crda
  8. Multi-Arch: foreign'
  9. insertpackage 'unstable-m' 'crda' 'i386,amd64' '1.1.1-1ubuntu4m' 'Multi-Arch: foreign'
  10. insertpackage 'unstable-p' 'crda' 'i386,amd64' '1.1.1-1ubuntu4p' 'Provides: wireless-crda'
  11. insertpackage 'unstable' 'wireless-crda' 'i386,amd64' '1.16'
  12. insertinstalledpackage 'wireless-crda' 'amd64' '1.14'
  13. setupaptarchive
  14. testsuccessequal 'Reading package lists...
  15. Building dependency tree...
  16. The following NEW packages will be installed:
  17. crda
  18. 0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
  19. Inst crda (1.1.1-1ubuntu4m unstable-m [amd64])
  20. Conf crda (1.1.1-1ubuntu4m unstable-m [amd64])' aptget install crda -s -t unstable-m
  21. testsuccessequal 'Reading package lists...
  22. Building dependency tree...
  23. The following NEW packages will be installed:
  24. crda
  25. 0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
  26. Inst crda (1.1.1-1ubuntu4p unstable-p [amd64])
  27. Conf crda (1.1.1-1ubuntu4p unstable-p [amd64])' aptget install crda -s -t unstable-p
  28. testsuccessequal 'Reading package lists...
  29. Building dependency tree...
  30. The following NEW packages will be installed:
  31. crda
  32. 0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
  33. Inst crda (1.1.1-1ubuntu4mp unstable-mp [amd64])
  34. Conf crda (1.1.1-1ubuntu4mp unstable-mp [amd64])' aptget install crda -s -t unstable-mp
  35. rm rootdir/var/lib/dpkg/status
  36. insertinstalledpackage 'crda' 'amd64' '1.1.1-1ubuntu4mp' 'Provides: wireless-crda
  37. Conflicts: wireless-crda (<< 1.15)
  38. Replaces: wireless-crda ( << 1.15)
  39. Multi-arch: foreign'
  40. testsuccessequal 'Reading package lists...
  41. Building dependency tree...
  42. The following NEW packages will be installed:
  43. wireless-crda
  44. 0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
  45. Inst wireless-crda (1.16 unstable [amd64])
  46. Conf wireless-crda (1.16 unstable [amd64])' aptget install wireless-crda -s -t unstable