You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

444 lines
23 KiB

  1. #!/bin/sh
  2. set -e
  3. TESTDIR="$(readlink -f "$(dirname "$0")")"
  4. . "$TESTDIR/framework"
  5. setupenvironment
  6. configarchitecture "i386"
  7. insertpackage 'unstable' 'libc6' 'i386' '2.11.2-7+sid'
  8. insertpackage 'unstable' 'phonon-backend-xine' 'i386' '4:4.6.0really4.4.2-1+sid' 'Provides: phonon-backend'
  9. insertpackage 'unstable' 'phonon-backend-xine2' 'i386' '4:4.6.0really4.4.2-1+sid'
  10. insertpackage 'unstable' 'phonon-backend-xine3' 'i386' '4:4.6.0really4.4.2-1+sid'
  11. insertpackage 'unstable' 'phonon-backend-xine4' 'i386' '4:4.6.0really4.4.2-1+sid'
  12. insertpackage 'unstable' 'phonon-backend-null' 'i386' '4:4.20.0+sid' 'Provides: phonon-backend'
  13. insertpackage 'unstable' 'intermediatepkg' 'all' '1.0'
  14. insertpackage 'unstable' 'amarok-common' 'all' '2.3.1-1+sid'
  15. insertpackage 'unstable' 'amarok-utils' 'i386' '2.3.1-1+sid'
  16. insertpackage 'unstable' 'libmtp8' 'i386' '0.3.1+sid'
  17. insertpackage 'unstable' 'amarok' 'i386' '2.3.1-1+sid' 'Depends: amarok-common (= 2.3.1-1+sid), amarok-utils (= 2.3.1-1+sid), phonon-backend-xine | phonon-backend, libmtp8 (>= 0.3.1), libc6'
  18. insertpackage 'experimental' 'amarok-common' 'all' '2.3.2-2+exp'
  19. insertpackage 'experimental' 'amarok-utils' 'i386' '2.3.2-2+exp'
  20. insertpackage 'experimental' 'libmtp8' 'i386' '0.3.3+exp'
  21. insertpackage 'experimental' 'phonon-backend-xine' 'i386' '5:4.6.0+exp' 'Provides: phonon-backend'
  22. insertpackage 'experimental' 'phonon-backend-xine2' 'i386' '5:4.6.0+exp' 'Depends: uninstallablepkg
  23. Provides: phonon-backend-broken'
  24. insertpackage 'experimental' 'phonon-backend-xine3' 'i386' '5:4.6.0+exp' 'Depends: intermediatepkg (>= 1.5)'
  25. insertpackage 'experimental' 'phonon-backend-xine4' 'i386' '5:4.6.0+exp' 'Depends: intermediateuninstallablepkg (= 2.0)
  26. Provides: phonon-backend-broken'
  27. insertpackage 'experimental' 'intermediatepkg' 'all' '2.0' 'Depends: libc6'
  28. insertpackage 'experimental' 'intermediateuninstallablepkg' 'all' '2.0' 'Depends: uninstallablepkg'
  29. insertpackage 'experimental' 'phonon-backend-null' 'i386' '5:4.20.0+exp' 'Provides: phonon-backend'
  30. insertpackage 'experimental' 'amarok' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), amarok-utils (= 2.3.2-2+exp), phonon-backend-xine | phonon-backend, libmtp8 (>= 0.3.1), libc6'
  31. insertpackage 'experimental2' 'phonon-backend-xine' 'i386' '5:4.00.0+exp' 'Provides: phonon-backend'
  32. insertpackage 'experimental2' 'amarok-less' 'i386' '2.3.2-2+exp' 'Depends: amarok-common, phonon-backend-xine (>= 5:4.00.0+exp), libmtp8, libc6, amarok-utils'
  33. insertpackage 'experimental' 'amarok-higher' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-xine (>= 5:4.6.0+exp), libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  34. insertpackage 'experimental' 'amarok-null' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-xine (= 1:1.0-1) | phonon-backend, libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  35. insertpackage 'experimental' 'amarok-null2' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-null (= 1:1.0-1) | phonon-backend, libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  36. insertpackage 'experimental' 'amarok-xine' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-xine (= 5:4.6.0+exp) | phonon-backend-null (= 5:4.20.0+exp), libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  37. insertpackage 'experimental' 'amarok-xine2' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-xine2 (= 5:4.6.0+exp) | phonon-backend-null (= 5:4.20.0+exp), libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  38. insertpackage 'experimental' 'amarok-xine3' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-xine3 (= 5:4.6.0+exp) | phonon-backend-null (= 5:4.20.0+exp), libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  39. insertpackage 'experimental' 'amarok-xine4' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-xine4 (= 5:4.6.0+exp) | phonon-backend-null (= 5:4.20.0+exp), libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  40. insertpackage 'experimental' 'amarok-broken' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp), phonon-backend-broken | phonon-backend-null (= 5:4.20.0+exp), libmtp8 (>= 0.3.1), libc6, amarok-utils (= 2.3.2-2+exp)'
  41. insertpackage 'experimental' 'amarok-recommends' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp)
  42. Recommends: amarok-utils (= 2.3.2-2+exp), phonon-backend-xine | phonon-backend, libmtp8 (>= 0.3.1), libc6'
  43. insertpackage 'experimental' 'amarok-recommends2' 'i386' '2.3.2-2+exp' 'Depends: amarok-common (= 2.3.2-2+exp)
  44. Recommends: amarok-utils (= 2.30.2-2+exp), phonon-backend-xine | phonon-backend, libmtp8 (>= 0.3.1), libc6'
  45. insertpackage 'experimental' 'uninstallablepkg' 'all' '1.0' 'Depends: libmtp8 (>= 10:0.20.1), amarok-utils (= 2.3.2-2+exp)'
  46. setupaptarchive
  47. testfailureequal "Reading package lists...
  48. Building dependency tree...
  49. The following additional packages will be installed:
  50. amarok-common (2.3.1-1+sid)
  51. amarok-utils (2.3.1-1+sid)
  52. libc6 (2.11.2-7+sid)
  53. libmtp8 (0.3.1+sid)
  54. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  55. The following NEW packages will be installed:
  56. amarok (2.3.1-1+sid)
  57. amarok-common (2.3.1-1+sid)
  58. amarok-utils (2.3.1-1+sid)
  59. libc6 (2.11.2-7+sid)
  60. libmtp8 (0.3.1+sid)
  61. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  62. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  63. After this operation, 258 kB of additional disk space will be used.
  64. E: Trivial Only specified but this is not a trivial operation." aptget install amarok --trivial-only -V
  65. testfailureequal "Reading package lists...
  66. Building dependency tree...
  67. The following additional packages will be installed:
  68. amarok-common (2.3.2-2+exp)
  69. amarok-utils (2.3.2-2+exp)
  70. libc6 (2.11.2-7+sid)
  71. libmtp8 (0.3.3+exp)
  72. phonon-backend-xine (5:4.6.0+exp)
  73. The following NEW packages will be installed:
  74. amarok (2.3.2-2+exp)
  75. amarok-common (2.3.2-2+exp)
  76. amarok-utils (2.3.2-2+exp)
  77. libc6 (2.11.2-7+sid)
  78. libmtp8 (0.3.3+exp)
  79. phonon-backend-xine (5:4.6.0+exp)
  80. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  81. After this operation, 258 kB of additional disk space will be used.
  82. E: Trivial Only specified but this is not a trivial operation." aptget install amarok -t experimental --trivial-only -V
  83. testfailureequal "Reading package lists...
  84. Building dependency tree...
  85. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok'
  86. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok'
  87. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok'
  88. The following additional packages will be installed:
  89. amarok-common (2.3.2-2+exp)
  90. amarok-utils (2.3.2-2+exp)
  91. libc6 (2.11.2-7+sid)
  92. libmtp8 (0.3.1+sid)
  93. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  94. The following NEW packages will be installed:
  95. amarok (2.3.2-2+exp)
  96. amarok-common (2.3.2-2+exp)
  97. amarok-utils (2.3.2-2+exp)
  98. libc6 (2.11.2-7+sid)
  99. libmtp8 (0.3.1+sid)
  100. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  101. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  102. After this operation, 258 kB of additional disk space will be used.
  103. E: Trivial Only specified but this is not a trivial operation." aptget install amarok/experimental --trivial-only -V
  104. testfailureequal "Reading package lists...
  105. Building dependency tree...
  106. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-null'
  107. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-null'
  108. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-null'
  109. The following additional packages will be installed:
  110. amarok-common (2.3.2-2+exp)
  111. amarok-utils (2.3.2-2+exp)
  112. libc6 (2.11.2-7+sid)
  113. libmtp8 (0.3.1+sid)
  114. phonon-backend-null (4:4.20.0+sid)
  115. The following NEW packages will be installed:
  116. amarok-common (2.3.2-2+exp)
  117. amarok-null (2.3.2-2+exp)
  118. amarok-utils (2.3.2-2+exp)
  119. libc6 (2.11.2-7+sid)
  120. libmtp8 (0.3.1+sid)
  121. phonon-backend-null (4:4.20.0+sid)
  122. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  123. After this operation, 258 kB of additional disk space will be used.
  124. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-null/experimental --trivial-only -V
  125. # do not select the same version multiple times
  126. testfailureequal "Reading package lists...
  127. Building dependency tree...
  128. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok'
  129. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok'
  130. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok'
  131. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-null'
  132. The following additional packages will be installed:
  133. amarok-common (2.3.2-2+exp)
  134. amarok-utils (2.3.2-2+exp)
  135. libc6 (2.11.2-7+sid)
  136. libmtp8 (0.3.1+sid)
  137. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  138. The following NEW packages will be installed:
  139. amarok (2.3.2-2+exp)
  140. amarok-common (2.3.2-2+exp)
  141. amarok-null (2.3.2-2+exp)
  142. amarok-utils (2.3.2-2+exp)
  143. libc6 (2.11.2-7+sid)
  144. libmtp8 (0.3.1+sid)
  145. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  146. 0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
  147. After this operation, 301 kB of additional disk space will be used.
  148. E: Trivial Only specified but this is not a trivial operation." aptget install amarok/experimental amarok-null/experimental --trivial-only -V
  149. # … but thighten the version if needed
  150. # in theory, the second line is wrong, but printing the right version is too much of a hassle
  151. # (we have to check if later in the Changed list is another change and if so use this version
  152. # instead of the current candidate) - and it wouldn't be (really) useful anyway…
  153. testfailureequal "Reading package lists...
  154. Building dependency tree...
  155. Selected version '2.3.2-2+exp' (experimental2 [i386]) for 'amarok-less'
  156. Selected version '5:4.6.0+exp' (experimental [i386]) for 'phonon-backend-xine' because of 'amarok-less'
  157. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-higher'
  158. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-higher'
  159. Selected version '5:4.6.0+exp' (experimental [i386]) for 'phonon-backend-xine' because of 'amarok-higher'
  160. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-higher'
  161. The following additional packages will be installed:
  162. amarok-common (2.3.2-2+exp)
  163. amarok-utils (2.3.2-2+exp)
  164. libc6 (2.11.2-7+sid)
  165. libmtp8 (0.3.1+sid)
  166. phonon-backend-xine (5:4.6.0+exp)
  167. The following NEW packages will be installed:
  168. amarok-common (2.3.2-2+exp)
  169. amarok-higher (2.3.2-2+exp)
  170. amarok-less (2.3.2-2+exp)
  171. amarok-utils (2.3.2-2+exp)
  172. libc6 (2.11.2-7+sid)
  173. libmtp8 (0.3.1+sid)
  174. phonon-backend-xine (5:4.6.0+exp)
  175. 0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
  176. After this operation, 301 kB of additional disk space will be used.
  177. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-less/experimental2 amarok-higher/experimental --trivial-only -V
  178. # phonon-backend-null can't be used directly, but as it provides it is still fine…
  179. testfailureequal "Reading package lists...
  180. Building dependency tree...
  181. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-null2'
  182. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-null2'
  183. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-null2'
  184. The following additional packages will be installed:
  185. amarok-common (2.3.2-2+exp)
  186. amarok-utils (2.3.2-2+exp)
  187. libc6 (2.11.2-7+sid)
  188. libmtp8 (0.3.1+sid)
  189. phonon-backend-null (4:4.20.0+sid)
  190. The following NEW packages will be installed:
  191. amarok-common (2.3.2-2+exp)
  192. amarok-null2 (2.3.2-2+exp)
  193. amarok-utils (2.3.2-2+exp)
  194. libc6 (2.11.2-7+sid)
  195. libmtp8 (0.3.1+sid)
  196. phonon-backend-null (4:4.20.0+sid)
  197. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  198. After this operation, 258 kB of additional disk space will be used.
  199. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-null2/experimental --trivial-only -V
  200. # if an or-group satisfier is already found, do not set others
  201. testfailureequal "Reading package lists...
  202. Building dependency tree...
  203. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-xine'
  204. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-xine'
  205. Selected version '5:4.6.0+exp' (experimental [i386]) for 'phonon-backend-xine' because of 'amarok-xine'
  206. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-xine'
  207. The following additional packages will be installed:
  208. amarok-common (2.3.2-2+exp)
  209. amarok-utils (2.3.2-2+exp)
  210. libc6 (2.11.2-7+sid)
  211. libmtp8 (0.3.1+sid)
  212. phonon-backend-xine (5:4.6.0+exp)
  213. The following NEW packages will be installed:
  214. amarok-common (2.3.2-2+exp)
  215. amarok-utils (2.3.2-2+exp)
  216. amarok-xine (2.3.2-2+exp)
  217. libc6 (2.11.2-7+sid)
  218. libmtp8 (0.3.1+sid)
  219. phonon-backend-xine (5:4.6.0+exp)
  220. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  221. After this operation, 258 kB of additional disk space will be used.
  222. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-xine/experimental --trivial-only -V
  223. # … but proceed testing if the first doesn't work out
  224. testfailureequal "Reading package lists...
  225. Building dependency tree...
  226. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-xine2'
  227. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-xine2'
  228. Selected version '5:4.20.0+exp' (experimental [i386]) for 'phonon-backend-null' because of 'amarok-xine2'
  229. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-xine2'
  230. The following additional packages will be installed:
  231. amarok-common (2.3.2-2+exp)
  232. amarok-utils (2.3.2-2+exp)
  233. libc6 (2.11.2-7+sid)
  234. libmtp8 (0.3.1+sid)
  235. phonon-backend-null (5:4.20.0+exp)
  236. The following NEW packages will be installed:
  237. amarok-common (2.3.2-2+exp)
  238. amarok-utils (2.3.2-2+exp)
  239. amarok-xine2 (2.3.2-2+exp)
  240. libc6 (2.11.2-7+sid)
  241. libmtp8 (0.3.1+sid)
  242. phonon-backend-null (5:4.20.0+exp)
  243. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  244. After this operation, 258 kB of additional disk space will be used.
  245. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-xine2/experimental --trivial-only -V
  246. # sometimes, the second level need to be corrected, too
  247. testfailureequal "Reading package lists...
  248. Building dependency tree...
  249. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-xine3'
  250. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-xine3'
  251. Selected version '5:4.6.0+exp' (experimental [i386]) for 'phonon-backend-xine3' because of 'amarok-xine3'
  252. Selected version '2.0' (experimental [all]) for 'intermediatepkg' because of 'phonon-backend-xine3'
  253. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-xine3'
  254. The following additional packages will be installed:
  255. amarok-common (2.3.2-2+exp)
  256. amarok-utils (2.3.2-2+exp)
  257. intermediatepkg (2.0)
  258. libc6 (2.11.2-7+sid)
  259. libmtp8 (0.3.1+sid)
  260. phonon-backend-xine3 (5:4.6.0+exp)
  261. The following NEW packages will be installed:
  262. amarok-common (2.3.2-2+exp)
  263. amarok-utils (2.3.2-2+exp)
  264. amarok-xine3 (2.3.2-2+exp)
  265. intermediatepkg (2.0)
  266. libc6 (2.11.2-7+sid)
  267. libmtp8 (0.3.1+sid)
  268. phonon-backend-xine3 (5:4.6.0+exp)
  269. 0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
  270. After this operation, 301 kB of additional disk space will be used.
  271. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-xine3/experimental --trivial-only -V
  272. # … but proceed testing if the first doesn't work out even in second deep
  273. testfailureequal "Reading package lists...
  274. Building dependency tree...
  275. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-xine4'
  276. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-xine4'
  277. Selected version '5:4.20.0+exp' (experimental [i386]) for 'phonon-backend-null' because of 'amarok-xine4'
  278. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-xine4'
  279. The following additional packages will be installed:
  280. amarok-common (2.3.2-2+exp)
  281. amarok-utils (2.3.2-2+exp)
  282. libc6 (2.11.2-7+sid)
  283. libmtp8 (0.3.1+sid)
  284. phonon-backend-null (5:4.20.0+exp)
  285. The following NEW packages will be installed:
  286. amarok-common (2.3.2-2+exp)
  287. amarok-utils (2.3.2-2+exp)
  288. amarok-xine4 (2.3.2-2+exp)
  289. libc6 (2.11.2-7+sid)
  290. libmtp8 (0.3.1+sid)
  291. phonon-backend-null (5:4.20.0+exp)
  292. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  293. After this operation, 258 kB of additional disk space will be used.
  294. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-xine4/experimental --trivial-only -V
  295. # providers can be broken, too
  296. testfailureequal "Reading package lists...
  297. Building dependency tree...
  298. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-broken'
  299. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-broken'
  300. Selected version '5:4.20.0+exp' (experimental [i386]) for 'phonon-backend-null' because of 'amarok-broken'
  301. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-broken'
  302. The following additional packages will be installed:
  303. amarok-common (2.3.2-2+exp)
  304. amarok-utils (2.3.2-2+exp)
  305. libc6 (2.11.2-7+sid)
  306. libmtp8 (0.3.1+sid)
  307. phonon-backend-null (5:4.20.0+exp)
  308. The following NEW packages will be installed:
  309. amarok-broken (2.3.2-2+exp)
  310. amarok-common (2.3.2-2+exp)
  311. amarok-utils (2.3.2-2+exp)
  312. libc6 (2.11.2-7+sid)
  313. libmtp8 (0.3.1+sid)
  314. phonon-backend-null (5:4.20.0+exp)
  315. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  316. After this operation, 258 kB of additional disk space will be used.
  317. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-broken/experimental --trivial-only -V
  318. # switch the candidate for recommends too if they should be installed
  319. testfailureequal "Reading package lists...
  320. Building dependency tree...
  321. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-recommends'
  322. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-recommends'
  323. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-utils' because of 'amarok-recommends'
  324. The following additional packages will be installed:
  325. amarok-common (2.3.2-2+exp)
  326. amarok-utils (2.3.2-2+exp)
  327. libc6 (2.11.2-7+sid)
  328. libmtp8 (0.3.1+sid)
  329. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  330. The following NEW packages will be installed:
  331. amarok-common (2.3.2-2+exp)
  332. amarok-recommends (2.3.2-2+exp)
  333. amarok-utils (2.3.2-2+exp)
  334. libc6 (2.11.2-7+sid)
  335. libmtp8 (0.3.1+sid)
  336. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  337. 0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
  338. After this operation, 258 kB of additional disk space will be used.
  339. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-recommends/experimental --trivial-only -V -o APT::Install-Recommends=1
  340. # … or not if not
  341. testfailureequal "Reading package lists...
  342. Building dependency tree...
  343. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-recommends'
  344. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-recommends'
  345. The following additional packages will be installed:
  346. amarok-common (2.3.2-2+exp)
  347. Recommended packages:
  348. amarok-utils (2.3.1-1+sid)
  349. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  350. | phonon-backend
  351. libmtp8 (0.3.1+sid)
  352. libc6 (2.11.2-7+sid)
  353. The following NEW packages will be installed:
  354. amarok-common (2.3.2-2+exp)
  355. amarok-recommends (2.3.2-2+exp)
  356. 0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
  357. After this operation, 86.0 kB of additional disk space will be used.
  358. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-recommends/experimental --trivial-only -V -o APT::Install-Recommends=0
  359. # but broken recommends are not the end of the world
  360. # FIXME: the version output for recommend packages is a bit strange… but what would be better?
  361. testfailureequal "Reading package lists...
  362. Building dependency tree...
  363. Selected version '2.3.2-2+exp' (experimental [i386]) for 'amarok-recommends2'
  364. Selected version '2.3.2-2+exp' (experimental [all]) for 'amarok-common' because of 'amarok-recommends2'
  365. The following additional packages will be installed:
  366. amarok-common (2.3.2-2+exp)
  367. libc6 (2.11.2-7+sid)
  368. libmtp8 (0.3.1+sid)
  369. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  370. Recommended packages:
  371. amarok-utils (2.3.1-1+sid)
  372. The following NEW packages will be installed:
  373. amarok-common (2.3.2-2+exp)
  374. amarok-recommends2 (2.3.2-2+exp)
  375. libc6 (2.11.2-7+sid)
  376. libmtp8 (0.3.1+sid)
  377. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  378. 0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
  379. After this operation, 215 kB of additional disk space will be used.
  380. E: Trivial Only specified but this is not a trivial operation." aptget install amarok-recommends2/experimental --trivial-only -V -o APT::Install-Recommends=1
  381. # if one depends doesn't work, we don't need to look deeper…
  382. testfailureequal "Reading package lists...
  383. Building dependency tree...
  384. Selected version '1.0' (experimental [all]) for 'uninstallablepkg'
  385. Some packages could not be installed. This may mean that you have
  386. requested an impossible situation or if you are using the unstable
  387. distribution that some required packages have not yet been created
  388. or been moved out of Incoming.
  389. The following information may help to resolve the situation:
  390. The following packages have unmet dependencies:
  391. uninstallablepkg : Depends: libmtp8 (>= 10:0.20.1) but it is not going to be installed
  392. Depends: amarok-utils (= 2.3.2-2+exp) but 2.3.1-1+sid is to be installed
  393. E: Unable to correct problems, you have held broken packages." aptget install uninstallablepkg/experimental --trivial-only -V
  394. insertinstalledpackage 'libmtp8' 'i386' '1'
  395. insertinstalledpackage 'amarok' 'i386' '3' 'Depends: amarok-common (= 3), libmtp8 (>= 1)'
  396. insertinstalledpackage 'amarok-common' 'all' '3'
  397. # note that libmtp8 isn't downgraded as there is no need
  398. testfailureequal "Reading package lists...
  399. Building dependency tree...
  400. Selected version '2.3.1-1+sid' (unstable [i386]) for 'amarok'
  401. Selected version '2.3.1-1+sid' (unstable [all]) for 'amarok-common' because of 'amarok'
  402. The following additional packages will be installed:
  403. amarok-common (2.3.1-1+sid)
  404. amarok-utils (2.3.1-1+sid)
  405. libc6 (2.11.2-7+sid)
  406. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  407. The following NEW packages will be installed:
  408. amarok-utils (2.3.1-1+sid)
  409. libc6 (2.11.2-7+sid)
  410. phonon-backend-xine (4:4.6.0really4.4.2-1+sid)
  411. The following packages will be DOWNGRADED:
  412. amarok (3 => 2.3.1-1+sid)
  413. amarok-common (3 => 2.3.1-1+sid)
  414. 0 upgraded, 3 newly installed, 2 downgraded, 0 to remove and 0 not upgraded.
  415. After this operation, 129 kB of additional disk space will be used.
  416. E: Trivial Only specified but this is not a trivial operation." apt install amarok/sid --trivial-only -V