You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

64 lines
3.3 KiB

  1. #!/bin/sh
  2. set -e
  3. TESTDIR="$(readlink -f "$(dirname "$0")")"
  4. . "$TESTDIR/framework"
  5. setupenvironment
  6. configarchitecture 'amd64'
  7. # the difference between version 3 and 4 is the new package 'ure' which
  8. # we have to unpack before we start configuring parts of the loop
  9. insertinstalledpackage 'libreoffice' 'amd64' '3' 'Depends: libreoffice-core (= 3)'
  10. insertinstalledpackage 'libreoffice-core' 'amd64' '3' 'Depends: libreoffice-common (>= 3)'
  11. insertinstalledpackage 'libreoffice-common' 'all' '3' 'Depends: libreoffice-style
  12. Breaks: libreoffice-core (>= 3+), libreoffice-core (<= 3~), libreoffice-style-galaxy (>= 3+), libreoffice-style-galaxy (<= 3~)'
  13. insertinstalledpackage 'libreoffice-style-galaxy' 'amd64' '3' 'Depends: libreoffice-core
  14. Provides: libreoffice-style'
  15. insertpackage 'sid' 'libreoffice' 'amd64' '4' 'Depends: libreoffice-core (= 4)'
  16. insertpackage 'sid' 'libreoffice-core' 'amd64' '4' 'Depends: libreoffice-common (>= 4)
  17. Breaks: libreoffice-common (<< 4), libreoffice-style-galaxy (<< 4)'
  18. insertpackage 'sid' 'libreoffice-common' 'all' '4' 'Depends: libreoffice-style, ure
  19. Breaks: libreoffice-core (>= 4+), libreoffice-core (<= 4~), libreoffice-style-galaxy (>= 4+), libreoffice-style-galaxy (<= 4~)'
  20. insertpackage 'sid' 'libreoffice-style-galaxy' 'amd64' '4' 'Depends: libreoffice-core
  21. Provides: libreoffice-style'
  22. insertpackage 'sid' 'ure' 'amd64' '4'
  23. setupaptarchive
  24. testequalor2 'Reading package lists...
  25. Building dependency tree...
  26. Calculating upgrade...
  27. The following NEW packages will be installed:
  28. ure
  29. The following packages will be upgraded:
  30. libreoffice libreoffice-common libreoffice-core libreoffice-style-galaxy
  31. 4 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
  32. Inst libreoffice [3] (4 sid [amd64]) []
  33. Inst libreoffice-style-galaxy [3] (4 sid [amd64]) [libreoffice-common:amd64 on libreoffice-style-galaxy:amd64] [libreoffice-common:amd64 ]
  34. Inst libreoffice-core [3] (4 sid [amd64]) [libreoffice-core:amd64 on libreoffice-common:amd64] [libreoffice-common:amd64 on libreoffice-core:amd64] [libreoffice-common:amd64 on libreoffice-style-galaxy:amd64] [libreoffice-common:amd64 ]
  35. Inst libreoffice-common [3] (4 sid [all]) []
  36. Inst ure (4 sid [amd64])
  37. Conf libreoffice (4 sid [amd64])
  38. Conf libreoffice-style-galaxy (4 sid [amd64])
  39. Conf libreoffice-core (4 sid [amd64])
  40. Conf libreoffice-common (4 sid [all])
  41. Conf ure (4 sid [amd64])' 'Reading package lists...
  42. Building dependency tree...
  43. Calculating upgrade...
  44. The following NEW packages will be installed:
  45. ure
  46. The following packages will be upgraded:
  47. libreoffice libreoffice-common libreoffice-core libreoffice-style-galaxy
  48. 4 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
  49. Inst libreoffice [3] (4 sid [amd64]) []
  50. Inst libreoffice-style-galaxy [3] (4 sid [amd64]) [libreoffice-common:amd64 on libreoffice-style-galaxy:amd64] [libreoffice-common:amd64 ]
  51. Inst libreoffice-core [3] (4 sid [amd64]) [libreoffice-common:amd64 on libreoffice-core:amd64] [libreoffice-common:amd64 on libreoffice-style-galaxy:amd64] [libreoffice-core:amd64 on libreoffice-common:amd64] [libreoffice-common:amd64 ]
  52. Inst libreoffice-common [3] (4 sid [all]) []
  53. Inst ure (4 sid [amd64])
  54. Conf libreoffice (4 sid [amd64])
  55. Conf libreoffice-style-galaxy (4 sid [amd64])
  56. Conf libreoffice-core (4 sid [amd64])
  57. Conf libreoffice-common (4 sid [all])
  58. Conf ure (4 sid [amd64])' aptget dist-upgrade -s