You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

33 lines
1.3 KiB

  1. #!/bin/sh
  2. set -e
  3. TESTDIR="$(readlink -f "$(dirname "$0")")"
  4. . "$TESTDIR/framework"
  5. setupenvironment
  6. configarchitecture 'i386'
  7. insertinstalledpackage 'libdb4.8' 'all' '1.0'
  8. insertinstalledpackage 'exim4' 'all' '1.0' 'Depends: exim4-daemon-light | exim4-daemon-heavy'
  9. insertinstalledpackage 'exim4-daemon-light' 'all' '1.0' 'Depends: libdb4.8'
  10. insertpackage 'unstable' 'exim4-daemon-heavy' 'all' '1.0' 'Depends: libdb4.8'
  11. setupaptarchive
  12. testsuccessequal 'Reading package lists...
  13. Building dependency tree...
  14. MarkDelete libdb4.8 [ i386 ] < 1.0 > ( other ) FU=1
  15. MarkDelete exim4-daemon-light [ i386 ] < 1.0 > ( other ) FU=0
  16. MarkInstall exim4-daemon-heavy [ i386 ] < none -> 1.0 > ( other ) FU=0
  17. Ignore MarkInstall of libdb4.8 [ i386 ] < 1.0 > ( other ) as its mode (Delete) is protected
  18. MarkDelete exim4-daemon-heavy [ i386 ] < none -> 1.0 > ( other ) FU=0
  19. MarkDelete exim4 [ i386 ] < 1.0 > ( other ) FU=0
  20. The following packages will be REMOVED:
  21. exim4 exim4-daemon-light libdb4.8
  22. MarkDelete exim4 [ i386 ] < 1.0 > ( other ) FU=1
  23. 0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
  24. Remv exim4 [1.0]
  25. MarkDelete exim4-daemon-light [ i386 ] < 1.0 > ( other ) FU=1
  26. Remv exim4-daemon-light [1.0]
  27. MarkDelete libdb4.8 [ i386 ] < 1.0 > ( other ) FU=1
  28. Remv libdb4.8 [1.0]' aptget remove libdb4.8 -s -o Debug::pkgDepCache::Marker=1