You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

156 lines
5.6 KiB

  1. Source: apt
  2. Section: admin
  3. Priority: important
  4. Maintainer: APT Development Team <deity@lists.debian.org>
  5. Uploaders: Michael Vogt <mvo@debian.org>,
  6. Julian Andres Klode <jak@debian.org>,
  7. David Kalnischkies <donkult@debian.org>
  8. Rules-Requires-Root: no
  9. Standards-Version: 4.1.1
  10. Build-Depends: cmake (>= 3.4),
  11. debhelper-compat (= 12),
  12. docbook-xml,
  13. docbook-xsl,
  14. dpkg-dev (>= 1.17.14),
  15. g++ (>= 4:7),
  16. gettext (>= 0.12),
  17. googletest <!nocheck> | libgtest-dev <!nocheck>,
  18. libbz2-dev,
  19. libdb-dev,
  20. libgnutls28-dev (>= 3.4.6),
  21. liblz4-dev (>= 0.0~r126),
  22. liblzma-dev,
  23. libseccomp-dev [amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el s390x hppa powerpc powerpcspe ppc64 x32],
  24. libsystemd-dev [linux-any],
  25. libudev-dev [linux-any],
  26. libzstd-dev (>= 1.0),
  27. ninja-build,
  28. pkg-config,
  29. po4a (>= 0.34-2),
  30. triehash,
  31. xsltproc,
  32. zlib1g-dev
  33. Build-Depends-Indep: doxygen, graphviz, w3m
  34. Vcs-Git: https://salsa.debian.org/apt-team/apt.git
  35. Vcs-Browser: https://salsa.debian.org/apt-team/apt
  36. Package: apt
  37. Architecture: any
  38. Depends: adduser,
  39. gpgv | gpgv2 | gpgv1,
  40. libapt-pkg6.0 (>= ${binary:Version}),
  41. ${apt:keyring},
  42. ${misc:Depends},
  43. ${shlibs:Depends}
  44. Replaces: apt-transport-https (<< 1.5~alpha4~), apt-utils (<< 1.3~exp2~)
  45. Breaks: apt-transport-https (<< 1.5~alpha4~),
  46. apt-utils (<< 1.3~exp2~),
  47. aptitude (<< 0.8.10)
  48. Provides: apt-transport-https (= ${binary:Version})
  49. Recommends: ca-certificates
  50. Suggests: apt-doc,
  51. aptitude | synaptic | wajig,
  52. dpkg-dev (>= 1.17.2),
  53. gnupg | gnupg2 | gnupg1,
  54. powermgmt-base
  55. Description: commandline package manager
  56. This package provides commandline tools for searching and
  57. managing as well as querying information about packages
  58. as a low-level access to all features of the libapt-pkg library.
  59. .
  60. These include:
  61. * apt-get for retrieval of packages and information about them
  62. from authenticated sources and for installation, upgrade and
  63. removal of packages together with their dependencies
  64. * apt-cache for querying available information about installed
  65. as well as installable packages
  66. * apt-cdrom to use removable media as a source for packages
  67. * apt-config as an interface to the configuration settings
  68. * apt-key as an interface to manage authentication keys
  69. Package: libapt-pkg6.0
  70. Architecture: any
  71. Multi-Arch: same
  72. Priority: optional
  73. Pre-Depends: ${misc:Pre-Depends}
  74. Depends: ${misc:Depends}, ${shlibs:Depends}
  75. Breaks: appstream (<< 0.9.0-3~), apt (<< 1.6~), aptitude (<< 0.8.9), libapt-inst1.5 (<< 0.9.9~)
  76. Recommends: apt (>= ${binary:Version})
  77. Section: libs
  78. Provides: libapt-pkg (= ${binary:Version})
  79. Description: package management runtime library
  80. This library provides the common functionality for searching and
  81. managing packages as well as information about packages.
  82. Higher-level package managers can depend upon this library.
  83. .
  84. This includes:
  85. * retrieval of information about packages from multiple sources
  86. * retrieval of packages and all dependent packages
  87. needed to satisfy a request either through an internal
  88. solver or by interfacing with an external one
  89. * authenticating the sources and validating the retrieved data
  90. * installation and removal of packages in the system
  91. * providing different transports to retrieve data over cdrom, ftp,
  92. http(s), rsh as well as an interface to add more transports like
  93. tor+http(s) (apt-transport-tor).
  94. Package: apt-doc
  95. Architecture: all
  96. Priority: optional
  97. Depends: ${misc:Depends}
  98. Section: doc
  99. Description: documentation for APT
  100. This package contains the user guide and offline guide for various
  101. APT tools which are provided in a html and a text-only version.
  102. Package: libapt-pkg-dev
  103. Architecture: any
  104. Multi-Arch: same
  105. Priority: optional
  106. Pre-Depends: ${misc:Pre-Depends}
  107. Depends: libapt-pkg (= ${binary:Version}),
  108. zlib1g-dev,
  109. ${misc:Depends}
  110. Section: libdevel
  111. Description: development files for APT's libapt-pkg and libapt-inst
  112. This package contains the header files and libraries for
  113. developing with APT's libapt-pkg Debian package manipulation
  114. library and the libapt-inst deb/tar/ar library.
  115. Package: libapt-pkg-doc
  116. Architecture: all
  117. Priority: optional
  118. Depends: ${misc:Depends}
  119. Section: doc
  120. Description: documentation for APT development
  121. This package contains documentation for development of the APT
  122. Debian package manipulation program and its libraries.
  123. .
  124. This includes the source code documentation generated by doxygen
  125. in html format.
  126. Package: apt-utils
  127. Architecture: any
  128. Depends: apt (= ${binary:Version}),
  129. ${misc:Depends},
  130. ${shlibs:Depends}
  131. Description: package management related utility programs
  132. This package contains some less used commandline utilities related
  133. to package management with APT.
  134. .
  135. * apt-extracttemplates is used by debconf to prompt for configuration
  136. questions before installation.
  137. * apt-ftparchive is used to create Packages and other index files
  138. needed to publish an archive of Debian packages
  139. * apt-sortpkgs is a Packages/Sources file normalizer.
  140. Package: apt-transport-https
  141. Architecture: all
  142. Multi-Arch: foreign
  143. Depends: apt (>= 1.5~alpha4), ${misc:Depends}
  144. Priority: optional
  145. Section: oldlibs
  146. Description: transitional package for https support
  147. This is a dummy transitional package - https support has been moved into
  148. the apt package in 1.5. It can be safely removed.