Project for generic devuan documentation (was devuan-doc)
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

2.5 KiB

This document describes how to upgrade to Devuan Chimaera from an existing Devuan system. This should not be used for migrations from Debian.

Upgrade to Chimaera

Warning: wicd will no longer be available after the upgrade, so if you use it to connect to the internet through wifi, you will be cut off. To prevent this, you should change to a connection manager that will still be available, such as connman. If you want a convnient graphical interface, without which making connections can be difficult, you should install connman-gtk. You should do this before you start the upgrade, or you will have trouble reconnecting if things go wrong.

Next you will need to change your sources.list so that it points to the Chimaera repositories.

root@devuan:~# editor /etc/apt/sources.list

Modify the sources.list to look like the one provided. Comment out all other lines.

deb http://deb.devuan.org/merged chimaera main
deb http://deb.devuan.org/merged chimaera-updates main
deb http://deb.devuan.org/merged chimaera-security main
#deb http://deb.devuan.org/merged chimaera-backports main

Update the package lists from the Chimaera repository.

root@devuan:~# apt-get update

Devuan Jessie users should now upgrade the Devuan repository keyring, and update the package lists again so packages can be authenticated.

root@devuan:~# apt-get install devuan-keyring root@devuan:~# apt-get update

If xscreensaver is running you should kill it now as it needs to be stopped before it can be upgraded.

root@devuan:~# killall xscreensaver

Now you can perform the upgrade.

root@devuan:~# apt-get dist-upgrade

In the event of any package failures you should fix the failed packages then start the upgrade again.

root@devuan:~# apt-get -f install
root@devuan:~# apt-get dist-upgrade

Users who migrated from ASCII and are using upower will need to downgrade their upower packages to avoid problems like bug #394.

root@devuan:~# apt-get install --allow-downgrades upower/chimaera gir1.2-upowerglib/chimaera

You may want to remove packages that were orphaned by the upgrade process and old package archives.

root@devuan:~# apt-get autoremove --purge
root@devuan:~# apt-get autoclean


**This work is released under the Creative Commons Attribution-ShareAlike 4.0 International [CC BY-SA 4.0] license. All trademarks are the property of their respective owners. This work is provided “AS IS” and comes with absolutely NO warranty.**