You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
16 lines
327 B
16 lines
327 B
#! /usr/bin/make -f
|
|
|
|
DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
|
|
DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
|
|
|
|
%:
|
|
dh $@
|
|
|
|
ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
|
|
CROSS :=
|
|
else
|
|
CROSS := CC=$(DEB_HOST_GNU_TYPE)-gcc
|
|
endif
|
|
|
|
override_dh_auto_build:
|
|
$(MAKE) small $(CROSS)
|
|
|