Browse Source

Add popcon version of wheezy

suites/ascii popcon-1.57
Bill Allombert 9 years ago
parent
commit
280ff278b6
  1. 7
      debian/changelog
  2. 5
      popcon.pl

7
debian/changelog

@ -1,14 +1,15 @@
popularity-contest (1.57) UNRELEASED; urgency=low
popularity-contest (1.57) unstable; urgency=low
* Please note when reading stats that wheezy was released with 1.56.
[ Bill Allombert ]
* debian/control:
- Fix grammar in Description. Closes: #699538 Thanks Chris Bannister.
* popcon.pl:
- add popcon version of wheezy
[ Christian Perrier ]
[ Debconf translations ]
* Kannada (Mallikarjuna). Closes: #694411
-- Bill Allombert <ballombe@debian.org> Sun, 05 May 2013 13:28:37 +0200
-- Bill Allombert <ballombe@debian.org> Sun, 05 May 2013 21:21:15 +0200
popularity-contest (1.56) unstable; urgency=low

5
popcon.pl

@ -11,7 +11,8 @@ my %popfile=('all' => "all-popcon-results.gz", 'stable' => "stable-popcon-result
my %poptext=('all' => "All reports", 'stable' => "Stable reports");
my $mirrorbase = "/srv/mirrors/debian";
my $docurlbase = "/";
my %popconver=("1.28" => "sarge", "1.41" => "etch", "1.46" => "lenny", "1.49" => "squeeze");
my %popconver=("1.28" => "sarge", "1.41" => "etch", "1.46" => "lenny",
"1.49" => "squeeze", "1.56" => "wheezy");
my %popver=();
my @dists=("main","contrib","non-free","non-US");
my @fields=("inst","vote","old","recent","no-files");
@ -517,7 +518,7 @@ sub read_packages
{
my ($file,$dist);
for $file ("slink","slink-nonUS","potato","potato-nonUS",
"woody","woody-nonUS","sarge","etch")
"woody","woody-nonUS", values %popconver)
{
open AVAIL, "<:utf8", "$file.sections" or die "Cannot open $file.sections";
while(<AVAIL>)

Loading…
Cancel
Save