Browse Source

ui/gtk2_ui: fix incomplete fallback to text ui

This fixes crashes when the python3-gi-cairo and gir1.2-vte-2.91
packages are not installed, so that the fallback can work in these
cases.
tags/7.1.5
Nis Martensen Sandro Tosi 4 years ago
parent
commit
fc7b8d1494
1 changed files with 2 additions and 0 deletions
  1. +2
    -0
      reportbug/ui/gtk2_ui.py

+ 2
- 0
reportbug/ui/gtk2_ui.py View File

@@ -46,6 +46,8 @@ try:

gi.require_version('Gtk', '3.0')
from gi.repository import Gtk

gi.require_foreign('cairo')
except ImportError:
raise UINotImportable('Please install the python3-gi and gir1.2-gtk-3.0 packages to use this interface.')



Loading…
Cancel
Save