Browse Source

Fix compilation with -Wl,--as-needed (bug #5103).

(Old svn revision: 29668)
upstream/xfce4-panel-4.10.1
Nick Schermer 13 years ago
parent
commit
c50163a420
  1. 1
      NEWS
  2. 2
      configure.in.in
  3. 1
      libxfce4panel/Makefile.am

1
NEWS

@ -1,6 +1,7 @@
4.6.1
=====
- Migrate launcher category icons from 4.4 panels (bug #5067).
- Fix compilation with -Wl,--as-needed (bug #5103).
4.6.0

2
configure.in.in

@ -205,7 +205,7 @@ fi
dnl ****************************************
dnl *** Check for ELF visibility support ***
dnl ****************************************
AC_ARG_ENABLE([visibility], AC_HELP_STRING([--disable-visibility], [Don't use ELF visibility attributes]), [], [enable_visibility=yes])
AC_ARG_ENABLE([visibility], AC_HELP_STRING([--disable-visibility], [Do not use ELF visibility attributes]), [], [enable_visibility=yes])
have_gnuc_visibility=no
if test x"$enable_visibility" != x"no"; then
dnl Check whether the compiler supports the visibility attribute

1
libxfce4panel/Makefile.am

@ -78,6 +78,7 @@ libxfce4panel_la_LDFLAGS += \
endif
libxfce4panel_la_LIBADD = \
-lX11 \
$(GTK_LIBS) \
$(LIBXFCE4UTIL_LIBS)

Loading…
Cancel
Save