You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

713 lines
24 KiB

  1. xfce4-panel (4.10.1-1+devuan1.2) unstable; urgency=medium
  2. * move alternatives rules to the proper locations
  3. -- Daniel Reurich <centurion@haggai.centurion.net.nz> Thu, 20 Apr 2017 23:57:33 +1200
  4. xfce4-panel (4.10.1-1+devuan1.1) unstable; urgency=medium
  5. * setup gbp.conf
  6. * add ignore-branch = True
  7. * enable gtk-doc
  8. -- Daniel Reurich <centurion@haggai.centurion.net.nz> Thu, 20 Apr 2017 23:40:21 +1200
  9. xfce4-panel (4.10.1-1+devuan1.0) unstable; urgency=medium
  10. * add additional deps required for git source build
  11. * run auto-gen
  12. * setup alternative
  13. * take over maintainership
  14. -- Daniel Reurich <centurion@haggai.centurion.net.nz> Wed, 19 Apr 2017 00:56:28 +1200
  15. xfce4-panel (4.10.1-1) unstable; urgency=low
  16. * New upstream release.
  17. * Upload to unstable.
  18. * debian/xfce4-panel.shlibs:
  19. - conflicts about a future 4.11 panel.
  20. * debian/xfce4-panel-dev.install:
  21. - static files are not built anymore, don't try to install them.
  22. * debian/rules:
  23. - enable all hardeningflags.
  24. -- Yves-Alexis Perez <corsac@debian.org> Tue, 21 May 2013 22:40:43 +0200
  25. xfce4-panel (4.10.0-1) experimental; urgency=low
  26. * New upstream stable release.
  27. * debian/control: revert to unversioned libxfce4util-dev, bump required
  28. versions for Xfce 4.10.
  29. -- Lionel Le Folgoc <mrpouit@gmail.com> Sat, 05 May 2012 13:35:45 +0200
  30. xfce4-panel (4.9.2-1) experimental; urgency=low
  31. * New upstream development release.
  32. * debian/xfce4-panel.shlibs, debian/xfce4-panel.lintian-overrides: updated
  33. to the new soname.
  34. -- Lionel Le Folgoc <mrpouit@gmail.com> Sun, 15 Apr 2012 15:54:14 +0200
  35. xfce4-panel (4.9.1-1) experimental; urgency=low
  36. [ Lionel Le Folgoc ]
  37. * New upstream development release, including:
  38. - "add items to panel" dialogs aren't on top anymore Closes: #450910
  39. - fix autosaving to avoid lost settings. Closes: #646981
  40. * debian/xfce4-panel.shlibs: bump to >= 4.9.1, for the new "small" property.
  41. * debian/rules, debian/xfce4-panel-dev.install: ignore *.a files, not built
  42. anymore.
  43. * debian/control:
  44. - switch to libxfceutil6-dev for the new api, and bump libxfce4ui-1-dev
  45. b-dep to >= 4.9.0 for the new help api.
  46. * debian/rules:
  47. - drop --sourcedir=debian/tmp from dh_install, unneeded.
  48. * debian/xfce4-panel.install: drop the docs, not build anymore.
  49. [ Yves-Alexis Perez ]
  50. * debian/control:
  51. - update debhelper build-dep to 9.
  52. - update standards version to 3.9.3
  53. * debian/rules:
  54. - build with --parallel.
  55. -- Lionel Le Folgoc <mrpouit@gmail.com> Sun, 08 Apr 2012 21:51:34 +0200
  56. xfce4-panel (4.8.6-4) unstable; urgency=low
  57. * debian/xfce4-panel.shlibs:
  58. - conflicts against development panel.
  59. * debian/rules:
  60. - build with --parallel.
  61. -- Yves-Alexis Perez <corsac@debian.org> Sat, 14 Apr 2012 15:31:07 +0200
  62. xfce4-panel (4.8.6-3) unstable; urgency=low
  63. [ Lionel Le Folgoc ]
  64. * Use maintscript support in dh_installdeb rather than writing out
  65. dpkg-maintscript-helper commands by hand. We now simply Pre-Depend on a
  66. new enough version of dpkg rather than using 'dpkg-maintscript-helper
  67. supports' guards, leading to more predictable behaviour on upgrades.
  68. Thanks Colin Watson for the patch Closes: #659887
  69. * debian/patches: add missing DEP3 headers.
  70. [ Yves-Alexis Perez ]
  71. * debian/control:
  72. - update standards version to 3.9.3.
  73. -- Lionel Le Folgoc <mrpouit@gmail.com> Sat, 03 Mar 2012 12:08:11 +0100
  74. xfce4-panel (4.8.6-2) unstable; urgency=low
  75. * debian/patches:
  76. - 02_fix-french-typo added, fix a typo in french translation, thanks Cyril
  77. Brulebois.
  78. * debian/control:
  79. - update debhelper build-dep to 9.
  80. -- Yves-Alexis Perez <corsac@debian.org> Wed, 08 Feb 2012 07:53:54 +0100
  81. xfce4-panel (4.8.6-1) unstable; urgency=low
  82. * New upstream release:
  83. - Fix segfault with not-existing menu. lp: #760939
  84. - Fix typo in fr.po for the directory menu plugin. lp: #846386
  85. * debian/xfce4-panel.1: fix path to upstream docs. Closes: #638204
  86. * debian/rules: switch hardening to use dh9 mode
  87. * debian/compat: use mode 9.
  88. * debian/control:
  89. - drop build-dep on hardening-includes
  90. - bump debhelper build-dep to 8.9.4 for dh9 compat mode.
  91. - add Pre-depends on ${misc:Pre-Depends}.
  92. * debian/rules: use multi-arch path in various rules.
  93. * debian/xfce4-panel-dev.install, debian/xfce4-panel.install: use
  94. multi-arch path.
  95. * debian/patches/01_support-non-multiarch-modules.patch: support modules
  96. installed in /usr/lib/$triplet and /usr/lib, to hopefully migrate smoothly
  97. panel plugins to multiarch path over time without breakage.
  98. -- Lionel Le Folgoc <mrpouit@gmail.com> Fri, 14 Oct 2011 18:57:33 +0200
  99. xfce4-panel (4.8.5-1) unstable; urgency=low
  100. * New upstream release.
  101. * debian/patches:
  102. - 01_fix-transparency-migration dropped, included upstream.
  103. -- Yves-Alexis Perez <corsac@debian.org> Wed, 22 Jun 2011 00:03:00 +0200
  104. xfce4-panel (4.8.4-1) unstable; urgency=low
  105. * New upstream bugfix release.
  106. * debian/patches:
  107. - 02_fix-arrow-spacing-vertical-panel.patch: dropped, included upstream.
  108. - series: refreshed.
  109. -- Lionel Le Folgoc <mrpouit@gmail.com> Mon, 20 Jun 2011 22:43:19 +0200
  110. xfce4-panel (4.8.3-3) unstable; urgency=low
  111. * debian/patches:
  112. - 02_fix-arrow-spacing-vertical-panel added, fix spacing between launchers
  113. on vertical panels with side arrows. closes: #625794
  114. * debian/rules:
  115. - ignore translations in .pc so dh_auto_test doesn't fail when make check
  116. is run in po/.
  117. -- Yves-Alexis Perez <corsac@debian.org> Sat, 14 May 2011 18:25:33 +0200
  118. xfce4-panel (4.8.3-2) unstable; urgency=low
  119. * debian/patches:
  120. - 01_fix-transparency-migration added, fix inversion when migrating
  121. transparency settings.
  122. -- Yves-Alexis Perez <corsac@debian.org> Fri, 29 Apr 2011 08:25:17 +0200
  123. xfce4-panel (4.8.3-1) unstable; urgency=low
  124. * New upstream bugfix release.
  125. * Upload to unstable.
  126. * debian/control:
  127. - remove Emanuele and Simon from uploaders thanks to them.
  128. - update standards version to 3.9.2.
  129. - update short descriptions.
  130. -- Yves-Alexis Perez <corsac@debian.org> Tue, 19 Apr 2011 16:25:59 +0200
  131. xfce4-panel (4.8.2-1) experimental; urgency=low
  132. * New upstream bugfix release.
  133. -- Yves-Alexis Perez <corsac@debian.org> Sun, 27 Feb 2011 00:55:05 +0100
  134. xfce4-panel (4.8.1-1) experimental; urgency=low
  135. [ Lionel Le Folgoc ]
  136. * New upstream bugfix release.
  137. * debian/control:
  138. - refreshed (b-)deps for this new major release
  139. - add myself to Uploaders
  140. - bump Standards-Version to 3.9.1.
  141. * debian/NEWS: dropped, unneeded.
  142. * debian/xfce4-panel.shlibs: refreshed, bump to (>= 4.7.2).
  143. * debian/xfce4-panel.lintian-overrides: refreshed, new lib name.
  144. * debian/xfce4-panel.preinst: added, handles removal of old conffiles.
  145. * debian/xfce4-panel.postinst: explicitly set -e.
  146. * debian/*.install: refreshed.
  147. * debian/rules:
  148. - call dpkg-buildflags
  149. - dropped rc files mangling as they don't exist anymore
  150. - updated removal of *.{l,}a files.
  151. - drop overrides for dh_auto_{configure,clean}, obsolete.
  152. * debian/xfce4-panel.{preinst,postinst,prerm}: use dpkg-maintscript-helper
  153. to remove pre-xfconf config files.
  154. * Bugs fixed by 4.7.x/4.8.x series:
  155. - rgba support lp: #586012
  156. - disappearing menus lp: #53897
  157. - xrandr support lp: #176174, Closes: #432914
  158. - Fails to reap children, creating zombies lp: #420187
  159. - DND of desktop-files on the panel to create new launchers Closes: #480380
  160. * Bumped shlibs to >= 4.7.7, abi break for external plugins.
  161. [ Yves-Alexis Perez ]
  162. * New upstream development release
  163. * debian/xfce4-panel.install:
  164. - install wrapper and migrate tools in xfce4-panel package
  165. - update plugins paths
  166. * debian/rules:
  167. - update path when removing .a/.la files for plugins.
  168. - add hardening flags to {C,LD}FLAGS
  169. * debian/control:
  170. - add build-dep on hardening-includes
  171. - update build-dep on garcon to 0.1.4.
  172. * debian/copyright updated for new release.
  173. -- Yves-Alexis Perez <corsac@debian.org> Sun, 06 Feb 2011 18:10:07 +0100
  174. xfce4-panel (4.6.4-1) unstable; urgency=low
  175. [Stefan Ott]
  176. * debian/watch edited to track Xfce archive reorganisation.
  177. [Yves-Alexis Perez]
  178. * New upstream release.
  179. * debian/xfce4-panel.shlibs
  180. - conflicts against development panel.
  181. * Switch to 3.0 (quilt) source format.
  182. * debian/rules:
  183. - switch to debhelper 7.
  184. * debian/control:
  185. - update standards version to 3.8.4.
  186. - update debhelper build-dep for overrides.
  187. -- Yves-Alexis Perez <corsac@debian.org> Sun, 23 May 2010 13:40:56 +0200
  188. xfce4-panel (4.6.3-1) unstable; urgency=low
  189. * New upstream release.
  190. * debian/control:
  191. - add depends on ${misc:Depends}.
  192. -- Yves-Alexis Perez <corsac@debian.org> Wed, 30 Dec 2009 19:38:15 +0100
  193. xfce4-panel (4.6.2-1) unstable; urgency=low
  194. * New upstream release.
  195. - fix italian translation. closes: #526459
  196. * debian/control:
  197. - update standards version to 3.8.3.
  198. - remove quilt build-dep.
  199. * debian/patches:
  200. - 01_use-exo-open-for-terminal dropped, included upstream.
  201. - 02_fix-session-restart-command as well.
  202. * debian/rules:
  203. - drop quilt stuff.
  204. -- Yves-Alexis Perez <corsac@debian.org> Sat, 17 Oct 2009 00:29:42 +0200
  205. xfce4-panel (4.6.1-3) unstable; urgency=low
  206. * debian/patches/
  207. - 02_fix-session-restart-command added, fix panel command saved in
  208. session to not use -r arg.
  209. * debian/control:
  210. - bump standards version to 3.8.2.
  211. -- Yves-Alexis Perez <corsac@debian.org> Thu, 25 Jun 2009 20:50:27 +0200
  212. xfce4-panel (4.6.1-2) unstable; urgency=low
  213. * debian/patches:
  214. - 1_use-exo-open-for-terminal added, use exo-open for launchers when
  215. using “run in terminal” option.
  216. * debian/control:
  217. - add build-dep on quilt.
  218. * debian/rules:
  219. - use quilt rules.
  220. -- Yves-Alexis Perez <corsac@debian.org> Tue, 09 Jun 2009 22:31:53 +0200
  221. xfce4-panel (4.6.1-1) unstable; urgency=low
  222. * New upstream release.
  223. - fix launchers arrow in vertical panel. closes: #524676
  224. * debian/patches:
  225. - 01_fix-wl-as-needed dropped, merged upstream.
  226. -- Yves-Alexis Perez <corsac@debian.org> Sun, 19 Apr 2009 14:37:59 +0200
  227. xfce4-panel (4.6.0-2) unstable; urgency=low
  228. * Upload to unstable.
  229. * debian/rules:
  230. - add -Wl,-z,defs -Wl,--as-needed to LDFLAGS.
  231. - re-add quilt rules.
  232. - replace dh_clean -k by dh_prep.
  233. * debian/control:
  234. - bump standards version to 3.8.1.
  235. - add build-dep on quilt.
  236. - bump debhelper build-dep to 7.
  237. - move to xfce section.
  238. * debian/compat bumped to 7.
  239. * debian/patches:
  240. - 01_fix-wl-as-needed added, fix build with -Wl,--as-needed.
  241. -- Yves-Alexis Perez <corsac@debian.org> Sat, 04 Apr 2009 01:13:33 +0200
  242. xfce4-panel (4.6.0-1) experimental; urgency=low
  243. [ Xfce 4.6 Alpha “Pinkie”]
  244. * New upstream alpha release.
  245. - plugin process are correctly terminated when removed. closes: #457395
  246. * debian/rules:
  247. - fail if dh_install misses files.
  248. - don't mess with config.{guess,sub} anymore.
  249. - call dh_lintian
  250. - don't use quilt rules.
  251. * debian/control:
  252. - drop build-dep on quilt.
  253. - update build-dep on debhelper for dh_lintian support.
  254. - add build-dep on intltool.
  255. - gq the long desc so they are on 80-cols.
  256. * add xfce4-popup-windowlist.1, thanks to François Wendling. closes: #496862
  257. * debian/xfce4-panel.shlibs: update shlibs to 4.5.90 (Xfce 4.6 Alpha).
  258. [ Xfce 4.6 Beta 1 “Fuzzy”]
  259. * New upstream beta release.
  260. * debian/control:
  261. - update build-deps for Fuzzy.
  262. - remove useless intltool from build-deps.
  263. - add build-dep on libxml-parser-perl.
  264. * debian/xfce4-panel.shlibs: bump shlibs.
  265. [ Xfce 4.6 Beta 2 “Hopper”]
  266. * New upstream beta release.
  267. * debian/control:
  268. - update build-deps for Hopper.
  269. * debian/xfce4-panel.shlibs:
  270. - bump shlibs for Hopper.
  271. [ Xfce 4.6 Beta 3 “Tuco-tuco”]
  272. * new upstream beta release.
  273. * debian/control:
  274. - update build-deps for “Tuco-Tuco”.
  275. - add build-dep on intltool.
  276. - add dep on libxfce4util-dev and libxfcegui4-dev to xfce4-panel-dev.
  277. [ Xfce 4.6 RC1 “Capybara” ]
  278. * new upstream release candidate.
  279. * debian/control:
  280. - update build-deps for “Capybara”.
  281. - update deps on -dev packages for “Capybara”.
  282. * debian/xfce4-panel.shlibs:
  283. - bump shlibs to 4.5.99.1.
  284. [ Xfce 4.6 ]
  285. * new upstream release.
  286. * debian/control:
  287. - update build-deps for 4.6.
  288. - update deps on -dev packages for 4.6.
  289. * debian/xfce4-panel.shlibs:
  290. - bump shlibs to 4.6.0.
  291. * debian/copyright:
  292. - update copyrights, dates and format.
  293. -- Yves-Alexis Perez <corsac@debian.org> Sat, 28 Feb 2009 12:38:19 +0100
  294. xfce4-panel (4.4.2-6) unstable; urgency=low
  295. * switch to triggers:
  296. - debian/postinst: remove xfce-mcs-manager refresh.
  297. - debian/prerm dropped.
  298. - debian/control: conflicts against non-triggers-enable xfce4-mcs-manager.
  299. * debian/control: remove useless Conflicts/Replaces against Sarge stuff.
  300. -- Yves-Alexis Perez <corsac@debian.org> Mon, 19 May 2008 08:08:22 +0200
  301. xfce4-panel (4.4.2-5) unstable; urgency=low
  302. * debian/patches:
  303. - 01_fix-dnd-file-panel added, fix a crash when drag & droping a file over
  304. the panel. (Xfce #3815, r26669).
  305. - 02_fix-screen-config-dialog added, fix multiscreen support for
  306. configuration dialogs. (Xfce r26937). closes: #481086
  307. * debian/rules: use quilt make rule.
  308. * debian/control: remove Martin Loschwitz from Uploaders:. Thanks for the
  309. work!
  310. -- Yves-Alexis Perez <corsac@debian.org> Thu, 15 May 2008 08:48:41 +0200
  311. xfce4-panel (4.4.2-4) unstable; urgency=low
  312. * debian/rules:
  313. - don't edit mousepad launcher…
  314. - and remove it.
  315. - remove editor launcher item from panel config. closes: #426164
  316. - use $(CURDIR) instead of `pwd`.
  317. -- Yves-Alexis Perez <corsac@debian.org> Sun, 06 Apr 2008 02:24:09 +0200
  318. xfce4-panel (4.4.2-3) unstable; urgency=low
  319. * debian/compat: bump debhelper compatibility to 5.
  320. * debian/control:
  321. - bump build-dep on debhelper accordingly.
  322. - update standards version to 3.7.3.
  323. - update my email address.
  324. - add a -dbg package
  325. * debian/rules: install debugging informations into -dbg package.
  326. * debian/copyright: use © sign.
  327. -- Yves-Alexis Perez <corsac@debian.org> Sun, 02 Mar 2008 01:01:52 +0100
  328. xfce4-panel (4.4.2-2) unstable; urgency=low
  329. * Add dependency on new exo-utils for exo-open
  330. -- Simon Huggins <huggie@earth.li> Mon, 28 Jan 2008 11:31:25 +0000
  331. xfce4-panel (4.4.2-1) unstable; urgency=low
  332. [ Simon Huggins ]
  333. * debian/control: Move fake Homepage field to a real one now dpkg
  334. supports it.
  335. [ Yves-Alexis Perez ]
  336. * New upstream release.
  337. * debian/patches:
  338. - removed 02_fix-segfault-gtk2.11.patch, included upstream.
  339. [ Simon Huggins ]
  340. * Add Vcs-* headers to debian/control
  341. -- Simon Huggins <huggie@earth.li> Tue, 27 Nov 2007 16:39:19 +0000
  342. xfce4-panel (4.4.1-2) unstable; urgency=low
  343. [ Simon Huggins ]
  344. * Use ${binary:Version} so we are binNMU safe.
  345. * debian/xfce4-panel.prerm: Use kill -s to keep Hurd and lintian happy at
  346. the same time.
  347. [ Yves-Alexis Perez ]
  348. * debian/xfce4-panel.1: update bug reporting in manpage.
  349. * debian/xfce4-panel.postinst: use posix kill -s closes: #374618
  350. * debian/patches: added 02_fix-segfault-gtk2.11.patch, fix segfault when
  351. removing a panel. closes: #446536
  352. [ Emanuele Rocca ]
  353. * debian/rules: do not ignore make errors in the clean target.
  354. -- Yves-Alexis Perez <corsac@corsac.net> Mon, 15 Oct 2007 22:54:48 +0200
  355. xfce4-panel (4.4.1-1) unstable; urgency=low
  356. * New upstream release.
  357. * debian/patch: added patch to reduce margin size of launchers.
  358. * debian/control: added versionned build-dep against gtk 2.10.
  359. * debian/copyright: updated copyright holders.
  360. -- Yves-Alexis Perez <corsac@corsac.net> Sun, 15 Apr 2007 15:28:17 +0100
  361. xfce4-panel (4.4.0-2) experimental; urgency=low
  362. * debian/rules: remove /usr/lib/libxfce4panel.la from the package.
  363. * debian/xfce4-panel.install: ship xfce4-panel-manager.desktop in
  364. /usr/share/applications.
  365. -- Yves-Alexis Perez <corsac@corsac.net> Thu, 25 Jan 2007 00:50:58 +0100
  366. xfce4-panel (4.4.0-1) experimental; urgency=low
  367. * New upstream release.
  368. * debian/control: updated build-deps against Xfce 4.4.
  369. -- Yves-Alexis Perez <corsac@corsac.net> Thu, 25 Jan 2007 00:06:03 +0100
  370. xfce4-panel (4.3.99.2-1) unstable; urgency=low
  371. * New upstream release.
  372. * debian/control: updated build-deps against Xfce 4.4RC2 (4.3.99.2).
  373. -- Yves-Alexis Perez <corsac@corsac.net> Thu, 16 Nov 2006 15:18:46 +0100
  374. xfce4-panel (4.3.99.1-1) unstable; urgency=low
  375. * New upstream release.
  376. * debian/control: updated build-dep against Xfce 4.4RC1 (4.3.99.1).
  377. -- Yves-Alexis Perez <corsac@corsac.net> Sat, 23 Sep 2006 13:40:01 +0100
  378. xfce4-panel (4.3.90.2-3) unstable; urgency=low
  379. * Bump shlibs file too.
  380. -- Simon Huggins <huggie@earth.li> Wed, 26 Jul 2006 15:47:42 +0100
  381. xfce4-panel (4.3.90.2-2) unstable; urgency=low
  382. * xfce4-panel should continue shipping xfce-filemanager.png as it has done
  383. since the beginning.
  384. * Add Replaces: on the bogus xfce4-mcs-plugins version.
  385. -- Yves-Alexis Perez <corsac@corsac.net> Tue, 25 Jul 2006 07:49:17 +0200
  386. xfce4-panel (4.3.90.2-1) unstable; urgency=low
  387. (Yves-Alexis Perez)
  388. * New upstream release.
  389. * debian/NEWS: fixed typo.
  390. * debian/postinst: fixed install on hurd by not using pkill. Closes: #374618
  391. * debian/control: updated standard versions to 3.7.2.
  392. (Simon Huggins)
  393. * Add rpath fixes.
  394. -- Yves-Alexis Perez <corsac@corsac.net> Fri, 21 Jul 2006 15:45:54 +0200
  395. xfce4-panel (4.3.90.1-3) unstable; urgency=low
  396. * (Simon Huggins)
  397. * Conflict/Replace -trigger-launcher too.
  398. * (Yves-Alexis Perez)
  399. * debian/NEWS: warn users they will lose their 4.2 panel config.
  400. -- Yves-Alexis Perez <corsac@corsac.net> Sat, 17 Jun 2006 12:37:27 +0100
  401. xfce4-panel (4.3.90.1-2) unstable; urgency=low
  402. * (Simon Huggins)
  403. * Add dependency on libexo-0.3-0 for exo-open which we use in our default
  404. panel config.
  405. * Ship the README.Plugins
  406. * (Yves-Alexis Perez)
  407. * Use the correct libexec dir
  408. -- Simon Huggins <huggie@earth.li> Sat, 13 May 2006 22:19:56 +0200
  409. xfce4-panel (4.3.90.1-1) unstable; urgency=low
  410. * New Upstream Release
  411. -- Yves-Alexis Perez <corsac@corsac.net> Wed, 03 May 2006 18:35:05 +0100
  412. xfce4-panel (4.2.3-1) unstable; urgency=low
  413. * New Upstream Release
  414. * Send xfce-mcs-manager a SIGUSR1 so it notices the plugin.
  415. -- Yves-Alexis Perez <corsac@corsac.net> Sun, 06 Nov 2005 22:01:12 +0100
  416. xfce4-panel (4.2.2-1) unstable; urgency=low
  417. * New Upstream Release
  418. * Remove Build-Depends on libstartup-notification0-dev as this should be
  419. satisfied via libxfce4gui-dev now
  420. * Remove Depends on debianutils, it is Essential
  421. * Change suite to unstable
  422. -- Simon Huggins <huggie@earth.li> Sat, 18 Jun 2005 09:46:08 +0100
  423. xfce4-panel (4.2.1.1-1) experimental; urgency=low
  424. * ML: New Upstream Release (Xfce 4.2.1.1)
  425. * ML: Upload to experimental to prevents problems with NEW packages
  426. * ML: debian/control: Added Maintainer/Uploaders fields
  427. -- Martin Loschwitz <madkiss@debian.org> Sat, 19 Mar 2005 13:02:00 +0100
  428. xfce4-panel (4.2.0-2) experimental; urgency=low
  429. * Add --enable-final to configure
  430. * Add a Homepage: to the description
  431. * Ship the README.Kiosk as well
  432. -- Simon Huggins <huggie@earth.li> Sun, 16 Jan 2005 15:49:21 +0000
  433. xfce4-panel (4.2.0-1) experimental; urgency=low
  434. * New Upstream Release
  435. * Conflict against all versions of xfce4-themes since upstream no longer
  436. ship this.
  437. -- Simon Huggins <huggie@earth.li> Sat, 15 Jan 2005 12:55:32 +0000
  438. xfce4-panel (4.1.99.1-1) experimental; urgency=low
  439. * ML: New Upstream Release (4.1.99.1 alias XFce4 4.2 RC1)
  440. -- Martin Loschwitz <madkiss@debian.org> Fri, 19 Nov 2004 18:04:00 +0100
  441. xfce4-panel (4.0.6-1) unstable; urgency=high
  442. * urgency high to avoid previous buildd mess; last upload stage building dev
  443. packages required before we can upload the rest (see
  444. http://wiki.earth.li/XfceDebian)
  445. * New upstream release
  446. - includes fix for non existant xfce-settings.xml closes: #254467
  447. * Update .no translation still not picked up upstream yet
  448. * Change mozilla to sensible-browser (and depend on debianutils which
  449. provides this) closes: #221835
  450. -- Simon Huggins <huggie@earth.li> Mon, 19 Jul 2004 17:40:59 +0100
  451. xfce4-panel (4.0.5-4) unstable; urgency=low
  452. * And extracting po/no.gmo so it builds, I also overwrote my lovingly
  453. updated libtool stuff.
  454. Update libtool once again. closes: #252927
  455. -- Simon Huggins <huggie@earth.li> Tue, 08 Jun 2004 10:44:21 +0100
  456. xfce4-panel (4.0.5-3) unstable; urgency=low
  457. * Except obviously whilst I don't mind installing the -dev package with the
  458. old one around I do want to build against the new libxfce4gui *sigh*
  459. Update the Build-Depends libxfce4gui dependency to the new version.
  460. -- Simon Huggins <huggie@earth.li> Fri, 28 May 2004 12:59:57 +0100
  461. xfce4-panel (4.0.5-2) unstable; urgency=low
  462. * Change the depends in the -dev pacage to be less strict >= instead of = so
  463. the new libxfcegui4-dev doesn't cause problems.
  464. -- Simon Huggins <huggie@earth.li> Wed, 26 May 2004 09:29:27 +0100
  465. xfce4-panel (4.0.5-1) unstable; urgency=high
  466. * urgency high to avoid previous buildd mess; last upload stage building dev
  467. packages required before we can upload the rest (see
  468. http://wiki.earth.li/XfceDebian)
  469. * New upstream release
  470. * Update upstream's libtool
  471. * Fix path to docs in manpage
  472. * Add libstartup-notification support to the panel
  473. * Typo in debian/control "wort" -> "worth"
  474. * Update .no translation not picked up upstream yet closes: #240275
  475. -- Simon Huggins <huggie@earth.li> Sun, 25 Apr 2004 13:13:55 +0100
  476. xfce4-panel (4.0.3-3) unstable; urgency=low
  477. * Fix the section in the control file closes: #236669
  478. * Update libtool
  479. * Just adding Daniel wasn't enough. Add self to Uploaders so katie doesn't
  480. think this is an NMU again.
  481. -- Simon Huggins <huggie@earth.li> Tue, 09 Mar 2004 09:55:04 +0000
  482. xfce4-panel (4.0.3-2) unstable; urgency=low
  483. * Add libxfcegui4-dev to the Depends closes: #232803
  484. -- Simon Huggins <huggie@earth.li> Sun, 07 Mar 2004 11:49:24 +0000
  485. xfce4-panel (4.0.3-1) unstable; urgency=low
  486. * New upstream release
  487. * Add Daniel Silverstone <dsilvers@debian.org> to Uploaders as approved by
  488. madkiss
  489. * Add xfce4-panel manpage to point at upstream documentation
  490. * Remove .la and .a files as these are only for the plugins
  491. * Thanks to Daniel for checking and uploading these packages
  492. -- Simon Huggins <huggie@earth.li> Wed, 25 Feb 2004 10:31:08 +0000
  493. xfce4-panel (4.0.2-2.1) unstable; urgency=low
  494. * NMU
  495. * Fix aclocal, add Depends: libxml2-dev to xfce4-panel-dev. Closes: #227606
  496. -- LaMont Jones <lamont@mmjgroup.com> Tue, 17 Feb 2004 11:33:56 -0700
  497. xfce4-panel (4.0.2-2) unstable; urgency=low
  498. * Adding Build-Dependency for libxfce4gui-dev
  499. -- Martin Loschwitz <madkiss@debian.org> Tue, 06 Jan 2003 12:01:00 +0100
  500. xfce4-panel (4.0.2-1) unstable; urgency=low
  501. * Acknowledging NMU (Closes: #215589)
  502. * New upstream release
  503. -- Martin Loschwitz <madkiss@debian.org> Fri, 26 Dec 2003 16:19:00 +0100
  504. xfce4-panel (4.0.0.final-1.1) unstable; urgency=low
  505. * NMU
  506. * Add xfce4-mcs-manager-dev to Build-Depends (Closes: #215589)
  507. * libxft-dev now Provides: libxft2-dev, so Build-Depend on that
  508. -- Guido Guenther <agx@debian.org> Thu, 20 Nov 2003 11:18:00 +0100
  509. xfce4-panel (4.0.0.final-1) unstable; urgency=low
  510. * Initial Release.
  511. -- Martin Loschwitz <madkiss@debian.org> Tue, 29 Sep 2003 17:09:09 +0200